aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-05-20 07:01:04 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-05-20 07:01:04 +0800
commit23d9d6a57093025ec73bf58ac5d2fea5af4f366f (patch)
tree1c7a14f29c877d67fe2f154eba21809ebcb4548e /Mk
parent72c0e19790cc25c5fafd8b177d3a6b19f4c83b80 (diff)
downloadfreebsd-ports-gnome-23d9d6a57093025ec73bf58ac5d2fea5af4f366f.tar.gz
freebsd-ports-gnome-23d9d6a57093025ec73bf58ac5d2fea5af4f366f.tar.zst
freebsd-ports-gnome-23d9d6a57093025ec73bf58ac5d2fea5af4f366f.zip
*****************************************************************************
Implement PKGNAMEPREFIX=ap13|ap20|ap22 ***************************************************************************** - Create packages for USE_APACHE=x ports with PKGNAMEPREFIX [1] - Rephrase IGNORE statement, kill EOL spaces, reformat in Mk/bsd.apache.mk [2] - Remove USE_APACHE=yes, USE_APACHE=apr, and APR_DEPS=foo - Remove APACHE_COMPAT=X - Drop support for 21 [dev only release, not in tree for years now] PR: ports/115461 [1], ports/133197 [2], ports/141688 Submitted by: myself (pgollucci@), Alexey Rubtsov <arubtsov@swsoft.com> [1], dafne [2] Requested by: Several [1] Tested by: 2 -exp runs by pav Approved by: portmgr (pav) With Hat: apache@
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.apache.mk55
1 files changed, 7 insertions, 48 deletions
diff --git a/Mk/bsd.apache.mk b/Mk/bsd.apache.mk
index 5ab1728807e8..69e26767078b 100644
--- a/Mk/bsd.apache.mk
+++ b/Mk/bsd.apache.mk
@@ -12,46 +12,20 @@
#
# Variables definition
# USE_APACHE: Call this script. Values can be:
-# <version>: 1.3/13/2.0/20/2.1/2.2/1.3+/2.0+/2.1+/2.2+
-# common*: common13, common20, common21 and common22
-#
-# Note: Setting USE_APACHE to "yes" is deprecated. It will set
-# APACHE_PORT to www/apache13 and if WITH_APACHE2 (deprecated too)
-# is defined, APACHE_PORT will be set to www/apache20
-#
+# <version>: 1.3/13/2.0/20/2.2/1.3+/2.0+/2.2+
+# common*: common13, common20, and common22
.if !defined(Apache_Pre_Include) || defined(PORT_IS_MODULE)
Apache_Pre_Include= bsd.apache.mk
-.if defined(APACHE_COMPAT)
-USE_APACHE=yes
-.endif
-
# Print warnings
_ERROR_MSG= : Error from bsd.apache.mk.
-APACHE_SUPPORTED_VERSION= 13 20 21 22
+APACHE_SUPPORTED_VERSION= 13 20 22
.if ${USE_APACHE:Mcommon*} != ""
AP_PORT_IS_SERVER= YES
-.elif ${USE_APACHE:L} == apr
-APR_DEPS= YES
-.elif ${USE_APACHE:C/\.//:C/\+//:M[12][3210]} != ""
+.elif ${USE_APACHE:C/\.//:C/\+//:M[12][320]} != ""
AP_PORT_IS_MODULE= YES
-
-#### for backward compatibility
-.elif ${USE_APACHE:L} == yes
-. if defined(WITH_APACHE2)
-APACHE_PORT?= www/apache20
-. else
-APACHE_PORT?= www/apache13
-. endif
-APXS?= ${LOCALBASE}/sbin/apxs
-.if !defined(APACHE_COMPAT)
-BUILD_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT}
-RUN_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT}
-.endif
-#### End of backward compatibility
-
.else
IGNORE= ${_ERROR_MSG} Illegal use of USE_APACHE
.endif
@@ -94,20 +68,6 @@ CONFIGURE_ARGS+= --disable-access --disable-auth \
--disable-asis --disable-cgid --disable-cgi \
--disable-negotiation --disable-dir --disable-imap \
--disable-actions --disable-userdir --disable-alias
-.elif ${USE_APACHE} == common21
-CONFIGURE_ARGS+= --disable-authn-file --disable-authn-default \
- --disable-authz-host --disable-authz-groupfile \
- --disable-authz-user --disable-authz-default \
- --disable-auth-basic --disable-charset-lite \
- --disable-include --disable-log-config --disable-env \
- --disable-setenvif --disable-mime --disable-status \
- --disable-autoindex --disable-asis --disable-cgid \
- --disable-cgi --disable-negotiation --disable-dir \
- --disable-imagemap --disable-actions --disable-userdir \
- --disable-alias --disable-filter \
- --disable-proxy --disable-proxy-connect \
- --disable-proxy-ftp --disable-proxy-http \
- --disable-proxy-ajp --disable-proxy-balancer
.elif ${USE_APACHE} == common22
CONFIGURE_ARGS+= --disable-authn-file --disable-authn-default \
--disable-authz-host --disable-authz-groupfile \
@@ -267,9 +227,6 @@ PLIST_SUB+= MOD_${module:U}=${${module}_PLIST_SUB}
.endfor
####End of PORT_IS_SERVER ####
-.elif defined(APR_DEPS)
-IGNORE= ${_ERROR_MSG} apr support is not yet implemented
-
.elif defined(AP_PORT_IS_MODULE)
AP_VERSION= ${USE_APACHE:C/\.//}
@@ -321,7 +278,7 @@ APACHEMODDIR= libexec/apache2
APACHEINCLUDEDIR=include/apache2
APACHEETCDIR= etc/apache2
APACHE_PORT?= www/apache${APACHE_VERSION}
-.elif ${APACHE_VERSION} >= 21
+.elif ${APACHE_VERSION} >= 22
AP_BUILDEXT= la
APACHEMODDIR= libexec/apache${APACHE_VERSION}
APACHEINCLUDEDIR=include/apache${APACHE_VERSION}
@@ -345,6 +302,8 @@ ${VAR} =${AP${APACHE_VERSION}_${VAR}}
. endif
.endfor
+PKGNAMEPREFIX?= ap${APACHE_VERSION}-
+
BUILD_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT}
RUN_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT}
PLIST_SUB+= AP_NAME="${SHORTMODNAME}"
td>2003-08-081-2/+14 * changed one of the "Con_fidential" to "Co_nfidential" since we alreadyJack Jia2003-08-061-1/+1 * Fixes #46769Harry Lu2003-07-291-26/+45 * Fix an unused variableDan Winship2003-07-231-1/+1 * Fixes #41676Rodrigo Moya2003-07-151-3/+58 * Changed the "URL:" label to "_Web Page:". Added a widget name to the URLFederico Mena Quintero2003-07-142-8/+23 * Fixes #45910Rodrigo Moya2003-07-071-0/+17 * Don't leak exceptions (load_static_capabilities): free the capabilityDan Winship2003-07-022-4/+6 * added a GtkWindow argument for callers to specify the parent window.Rodrigo Moya2003-06-3012-24/+36 * Fixes #44723Rodrigo Moya2003-06-271-0/+42 * new functions. (page_summary_changed_cb): change the window title when theRodrigo Moya2003-06-241-0/+50 * removed unused variable.Rodrigo Moya2003-06-201-1/+1 * unref not ref the clientJP Rosevear2003-05-231-1/+1 * Fixes #41234Rodrigo Moya2003-05-221-7/+8 * Change this dialog from using a gnome_message_box (which has beenAnna Marie Dirks2003-05-211-17/+20 * Added HIG-blessed padding to (some of) the widgets in the dialog.Anna Marie Dirks2003-05-202-4/+4 * the title is already in UTF-8JP Rosevear2003-05-181-4/+1 * unref the client and the ui componentJP Rosevear2003-05-161-2/+8 * fix button conversion problemJP Rosevear2003-05-082-17/+2 * unref the model again (task_editor_edit_comp): don't allow editing if theJP Rosevear2003-05-024-11/+11 * dittoJP Rosevear2003-04-302-2/+10 * Added HIG-blessed padding to the alarm options dialog. Fixes bug #41221.Anna Marie Dirks2003-04-291-3/+4 * Added appropriate spacing and padding to the calendar/tasks page of theAnna Marie Dirks2003-04-291-6/+7 * Finishes up fixing #41256 by adding appropriate spacing/padding to theAnna Marie Dirks2003-04-292-6/+7 * Added padding/spacing to this page as specified by the HIG. PartiallyAnna Marie Dirks2003-04-293-17/+18 * Fixes #37552JP Rosevear2003-04-253-0/+139 * Fixes part of #41148, #41216 and #41235Rodrigo Moya2003-04-235-11/+11 * [ fixes #21499 ]Rodney Dawes2003-04-192-1/+2 * Fixes #41459JP Rosevear2003-04-171-1/+4 * Fixes #41129, #41215, #41221, #41256Rodrigo Moya2003-04-1710-2544/+2775 * If we already have an evolution_dir, free the old one before setting itHans Petter Jansson2003-04-161-0/+5 * Oops. Add this back. Turns out it's still needed by other parts.Dan Winship2003-04-122-0/+15 * Remove the "Contacts" button and entry from here too. Supposed to haveDan Winship2003-04-116-424/+0 * added missing capabilities.Rodrigo Moya2003-04-114-9/+15 * unref the main widget since we ref it when we un-parent itJP Rosevear2003-04-117-1/+22 * Remove button_ok, button_cancel, canceled members from struct Dialog.Ettore Perazzoli2003-04-082-479/+430 * Fixes #35926.Hans Petter Jansson2003-04-082-130/+0 * create button properlyJP Rosevear2003-04-081-32/+0 * (alarm_to_dialog): Make the fileEttore Perazzoli2003-04-051-0/+6 * description is a text buffer (alarm_to_malarm_widgets): dittoJP Rosevear2003-04-051-6/+25 * Fixes #39954Hans Petter Jansson2003-03-291-4/+4 * init new members (get_current_account): get a matching account for theJP Rosevear2003-03-281-56/+113 * add a parameter(TC_CORBA_string) to the bonobo_widget_get_property.Jack Jia2003-03-261-1/+1 * Update for e_notice moveDan Winship2003-03-252-10/+10 * use a GtkMessageDialog and deal correctly with the dialog's reponses.Rodrigo Moya2003-03-211-4/+9 * use GtkMessageDialog instead of gnome_question_dialog, and deal correctlyRodrigo Moya2003-03-191-4/+9 * Fixes #34095Hans Petter Jansson2003-03-183-1/+5 * Fixes #39757Hans Petter Jansson2003-03-181-6/+10 * don't use GNOME_STOCK_* defines, but GTK_STOCK_*.Rodrigo Moya2003-03-131-3/+3 * corrected button ordering and changed the return type to be aRodrigo Moya2003-03-133-10/+17 * g_objectify ref/unrefJP Rosevear2003-03-051-1/+1 * don't let the user change to an email organizer if the back end is not anJP Rosevear2003-03-051-0/+2 * call cal_client_get_cal_address instead of cal_client_get_email_addressJP Rosevear2003-03-051-1/+1 * fix copyrightJP Rosevear2003-03-052-7/+7 * Partially Fixes #23606 (from Jack Jia <jack.jia@sun.com>)JP Rosevear2003-03-052-2/+13 * Shush.JP Rosevear2003-03-051-1/+3 * Commit missed files.JP Rosevear2003-03-052-0/+126 * If only the pipe wouldn't break.JP Rosevear2003-03-0520-2101/+2464 * gui/dialogs/alarm-page.c gui/dialogs/event-page.cHans Petter Jansson2003-03-047-7/+7 * build libcal-dialogs as an uninstalled shared library ($(IDL_GENERATED_H),Dan Winship2003-03-012-12/+6 * Show start/end-of-day widgets.Hans Petter Jansson2003-02-261-0/+2 * Don't warn if calendar isn't loaded... Doesn't seem to hurt, but thisHans Petter Jansson2003-02-243-3/+7 * gconf settings upgradesMichael Zucci2003-02-243-38/+51 * Appease the compiler. (gnome_calendar_update_paned_quanta): Don't actuallyHans Petter Jansson2003-02-242-0/+16 * Show the custom widgets, since libglade appears to not want to do that.Hans Petter Jansson2003-02-232-10/+32 * revert previous changeDan Winship2003-02-201-2/+2 * Remove libversit. We haven't depended on that in forever.Dan Winship2003-02-201-2/+2 * Make the CORBA IDL compilation work with parallel makes. Likewise.Ettore Perazzoli2003-02-111-3/+6 * Use e_auto_kill_popup_menu_on_selection_done() instead ofEttore Perazzoli2003-02-071-1/+1 * show the widget before returning it.Dan Winship2003-02-071-1/+5 * Remove cruft. Rename ICONSDIR to IMAGESDIR. (gladedir, etspecdir): RemoveDan Winship2003-02-066-20/+11 * array of localized month day names ("1st" - "31st")Dan Winship2003-02-061-47/+4 * The CVS server exited after applying everything from my last commit,Hans Petter2003-02-051-10/+22 * Skip setting the "font_gdk" arg for now.Hans Petter Jansson2003-02-022-0/+5 * Mainly making all views use PangoLayouts for text. When drawing aHans Petter Jansson2003-01-266-20/+13 * Don't insist appointment is updated if both old and new summary are blank.Hans Petter Jansson2003-01-252-107/+107 * Remove, this is now defined in configure.in.Ettore Perazzoli2003-01-251-2/+0 * Add a terminating NULL to the concatenation.Hans Petter Jansson2003-01-241-1/+1 * GTK_OBJECT -> G_OBJECT cast.Hans Petter Jansson2003-01-247-8/+8 * Fixes some trivial, but distracting, warnings.Hans Petter Jansson2003-01-243-5/+5 * Use EVOLUTION_GALVIEWSDIR.Ettore Perazzoli2003-01-232-5/+11 * Implement EAlarmList as CalComponentAlarm list with a GtkTreeModelHans Petter Jansson2003-01-174-60/+97 * Create accel groups for popup menus. Fixes crash.Hans Petter Jansson2003-01-161-82/+97 * Removed. Removed.Ettore Perazzoli2003-01-141-1/+2 * Icons are now in $(datadir)/evolution/images instead ofEttore Perazzoli2003-01-091-1/+1 * Replace gtk_signal_disconnect_by_data() withHans Petter Jansson2002-12-1911-390/+165 * run fix.sh over this.Not Zed2002-12-0227-332/+332 * Changed e_messagebox -> gtk_messagedialog.Not Zed2002-11-251-11/+6 * pass type to bonobo_widget::set_property. (select_names_ok_cb): ", forNot Zed2002-11-192-5/+8 * Initial port of gui/ subdir to GNOME 2JP Rosevear2002-11-0812-21/+22 * converted to BonoboObject.Rodrigo Moya2002-11-084-10/+8 * #include gtkoptionmenu.h. (cal_prefs_dialog_new): adapted to changes inRodrigo Moya2002-11-0714-72/+66 * don't return a Bonobo_EventSource_ListenerId, since it does not existRodrigo Moya2002-11-0712-4177/+4513 * adapted to to new glade_xml_new signature.Rodrigo Moya2002-11-075-8/+7 * use libxml2 headers.Rodrigo Moya2002-11-052-2/+1 * if the value is a datetime, convert it to a dateJP Rosevear2002-10-181-0/+24 * changed to have a gboolean return type, which is what it's supposed to do.Rodrigo Moya2002-10-182-7/+7 * Fixes #11434Rodrigo Moya2002-10-097-0/+85 * set the 24 hour format initiallyJP Rosevear2002-10-091-0/+1 * Fixes #31774Rodrigo Moya2002-10-081-2/+2 * cast the correct itemJP Rosevear2002-10-081-1/+1 * Fixes #30057Rodrigo Moya2002-10-032-9/+31 * Fixes #15710Rodrigo Moya2002-10-012-1/+47 * It's a grand old string-review! Nitpicky and minor changes; details in the ap...Aaron Weber2002-10-011-1/+1 * Non-Connector part of #29334 (meeting created by a delegate in theDan Winship2002-09-286-27/+72 * set the deleted attendees array to size 0 after we clean it upJP Rosevear2002-09-201-1/+2 * bump the month_num by 1 because it indexs at 0JP Rosevear2002-09-191-2/+4 * bail out if we couldn't send the cancelJP Rosevear2002-09-054-27/+46 * use bonobo_object_release_unref to release the remote SelectNamesMike Kestner2002-08-312-2/+2 * use EConfigListener instead of direct access to the bonobo-conf database.Rodrigo Moya2002-08-271-1/+0 * listen for the time editors to changeJP Rosevear2002-08-151-0/+59 * set the editor to changed so the item actually gets savedJP Rosevear2002-08-101-0/+2 * check for an attendee in the list (comp_to_list): only add the user ifJP Rosevear2002-08-091-1/+8 * Fixes #15710Rodrigo Moya2002-08-081-0/+23 * fixed mapping of popdown menu to ICAL_STATUS_ values.Rodrigo Moya2002-07-292-10/+16 * use util function to see if the user is the organizer72002-07-185-14/+30 * Add include lines to get ebook headers relative to <ebook/foo.h>, notPeter Williams2002-07-113-4/+4 * add back protoJP Rosevear2002-06-258-212/+313 * Fix a typo.Kjartan Maraas2002-06-131-1/+1 * In an attempt to clean up the config dialog (and to reduce its overallAnna Marie Dirks2002-06-041-179/+281 * update protoJP Rosevear2002-05-272-0/+14 * if there are remaining items, return false (foreach_close_cb): don'tJP Rosevear2002-05-272-5/+10 * a registry of comp editors so we can close them all centrallyJP Rosevear2002-05-272-13/+26 * Pass the @component_pixmaps in so we give the new "Meeting" button anEttore Perazzoli2002-05-214-4/+17 * added PermissionDenied exception and make it be raised in open,Rodrigo Moya2002-05-171-2/+21 * set the working hours for the meeting time selectorJP Rosevear2002-05-151-0/+6 * make the range datetime member a struct not a pointerJP Rosevear2002-05-151-1/+2 * Collapsed notebook into two pages and added accelerators for everything,Anna Marie Dirks2002-04-201-354/+326 * properly handle -ve recurrence valuesJP Rosevear2002-04-191-67/+256 * Bumped required gal version number to 0.19.99.11.Christopher James Lahey2002-04-181-5/+3 * ignore .pureChris Toshok2002-04-021-0/+1 * implement new pop up menu items for "Save as", "Print", "Assign Task",JP Rosevear2002-03-303-89/+55 * Updated to use new EPopupMenu API.Jeffrey Stedfast2002-03-161-5/+8 * Add <visible>False</visible> to cal-prefs-dialog so it doesn't get shownEttore Perazzoli2002-03-133-361/+267 * remove unneeded parameter from print_text_size everywhereJP Rosevear2002-03-061-2/+3 * pass extra itip_send_comp params (send_freebusy): ditto (ok_clicked_cb):JP Rosevear2002-02-203-5/+11 * change custom widget creator to e_url_entry_newJP Rosevear2002-02-092-41/+12 * add a custom widget created with e_url_button_newJP Rosevear2002-02-092-9/+43 * pass meeting boolean for gnome_calendar_edit_object andJP Rosevear2002-02-082-5/+23 * Use 1 instead of zero as the minimum value for the repetitions spin buttonFederico Mena Quintero2002-01-261-1/+1 * Clean up some of the Makefiles so we dont' link every library multipleEttore Perazzoli2002-01-251-4/+3 * save the alarm string in the correct variable (str), so it actually getsDamon Chaplin2002-01-181-2/+1 * default component classification to PUBLIC. Fixes internal bug #1066Rodrigo Moya2002-01-171-3/+5 * remove needs send signal related cruft (save_comp_with_send): withJP Rosevear2001-12-225-52/+22 * inherit from bonobo window12001-12-212-34/+50 * default component classification to PUBLICRodrigo Moya2001-12-071-3/+5 * Explicitly destroy the EMeetingModel. This is a hack to work aroundJon Trowbridge2001-12-071-0/+1 * added entry for the LOCATION fieldRodrigo Moya2001-12-062-2/+75 * new protosJP Rosevear2001-11-121-1/+2 * Convert strings to GTK+ encoding. (meeting_page_destroy): Free allocatedChyla Zbigniew2001-11-101-2/+5 * make sure to remove all attendees from the model when we edit a new comp,JP Rosevear2001-11-073-10/+22 * <ettore> ok so <ettore> should I build this tarball again? ettore doesn'tDan Winship2001-11-062-1/+2 * add a changed signal (e_meeting_time_selector_construct): emit changedJP Rosevear2001-11-062-25/+22 * Argh, missing commit from yesterday to fix building of the tarball.Ettore Perazzoli2001-11-021-1/+1 * Added rules to generate `Evolution-Addressbook-SelectNames.h'.Ettore Perazzoli2001-11-011-18/+32 * #include <string.h>Federico Mena Quintero2001-10-311-0/+1 * disconnect signals added in append_page(). Fixes Gtk-Critical warningDamon Chaplin2001-10-311-0/+5 * Add _() to a string that was missing it.Federico Mena Quintero2001-10-311-1/+1 * Commit the ETable click-to-add for if the dialog is being destroyed.Federico Mena Quintero2001-10-311-1/+23 * move in whole day increments if we are in all day modeJP Rosevear2001-10-311-4/+5 * count the actual attendees (doesn't include people delegatingJP Rosevear2001-10-311-2/+6 * set to the default timezone for DATE values, in case the user switches toDamon Chaplin2001-10-301-10/+9 * handle DATE values for Start and Due dates.Damon Chaplin2001-10-301-30/+60 * updated code to handle DATE values.Damon Chaplin2001-10-303-23/+52 * Fix bug #10016.Federico Mena Quintero2001-10-303-151/+138 * Use an EMessageBox instead of a gnome_dialog_question so that the labelFederico Mena Quintero2001-10-302-5/+30 * use libical-evolution.laDamon Chaplin2001-10-303-13/+51 * get the management object by idJP Rosevear2001-10-301-1/+0 * added break statements after each case, when setting the classification.Damon Chaplin2001-10-291-0/+6 * get the tasks directly from the CalendarModel, so we get the filtering &Damon Chaplin2001-10-291-2/+0 * when the week start day is set to Sunday, we have to be careful to makeDamon Chaplin2001-10-281-0/+25 * Delete appointments with empty summaries. Fixes Ximian bug #780.Federico Mena Quintero2001-10-283-3/+11 * Fixing the license text.Ettore Perazzoli2001-10-28