aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-08-18 20:29:06 +0800
committermat <mat@FreeBSD.org>2014-08-18 20:29:06 +0800
commit4098b36cd5177d1b59a30ac63b2436d15ebfea59 (patch)
tree929b0f1c3e87b913eed497715ee6f3b9e9c4fdc7 /Mk
parentb67f1c55e3e9faf30aaa533cf553d7474548f62e (diff)
downloadfreebsd-ports-gnome-4098b36cd5177d1b59a30ac63b2436d15ebfea59.tar.gz
freebsd-ports-gnome-4098b36cd5177d1b59a30ac63b2436d15ebfea59.tar.zst
freebsd-ports-gnome-4098b36cd5177d1b59a30ac63b2436d15ebfea59.zip
Module::Build installs the empty bootstrap files, even with Perl 5.20, so
remove the .if and always search and delete them. Noticed by: pi Sponsored by: Absolight
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/perl5.mk7
1 files changed, 3 insertions, 4 deletions
diff --git a/Mk/Uses/perl5.mk b/Mk/Uses/perl5.mk
index 97cab23e2f3d..8533bc046f25 100644
--- a/Mk/Uses/perl5.mk
+++ b/Mk/Uses/perl5.mk
@@ -264,12 +264,11 @@ fix-packlist::
-@[ -d ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}/${PERL_ARCH}/auto ] && ${FIND} ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}/${PERL_ARCH}/auto -name .packlist -exec ${SED} -i '' 's|^${STAGEDIR}||' '{}' \;
.endif
-# Starting with perl 5.20, the empty bootstrap files are not installed any
-# more. As we don't need them anyway, remove it altogether.
-.if ${PERL_LEVEL} < 502000
+# Starting with perl 5.20, the empty bootstrap files are not installed any more
+# by ExtUtils::MakeMaker. As we don't need them anyway, remove them.
+# Module::Build continues to install them, so inconditionnaly remove the files.
fix-perl-bs:
-@${FIND} ${STAGEDIR} -name '*.bs' -size 0 -delete
-.endif
.if !target(regression-test)
TEST_ARGS+= ${MAKE_ARGS}