aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authoralonso <alonso@FreeBSD.org>2015-06-01 06:56:44 +0800
committeralonso <alonso@FreeBSD.org>2015-06-01 06:56:44 +0800
commit4c21ecd8ef8c107507012c24b574c337c67ae43e (patch)
tree7153e5d481cbc9a27761739890c9bb1a809bf2dc /Mk
parent787a07a8d1bd89db14539cdefa75752eba1173b7 (diff)
downloadfreebsd-ports-gnome-4c21ecd8ef8c107507012c24b574c337c67ae43e.tar.gz
freebsd-ports-gnome-4c21ecd8ef8c107507012c24b574c337c67ae43e.tar.zst
freebsd-ports-gnome-4c21ecd8ef8c107507012c24b574c337c67ae43e.zip
Add a new port www/qt5-webchannel
Qt-5.4 introduced a new component: Qt WebChannel The Qt WebChannel module provides a library for seamless integration of C++ and QML applications with HTML/JavaScript clients. Any QObject can be published to remote clients, where its public API becomes available. https://doc-snapshots.qt.io/qt5-5.4/qtwebchannel-index.html Approved by: makc (mentor) Submitted by: Tobias Berner <tcberner@gmail.com> via area51 commit
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.qt.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/Mk/bsd.qt.mk b/Mk/bsd.qt.mk
index 8bd3c297e576..f1cb5e5e2b4f 100644
--- a/Mk/bsd.qt.mk
+++ b/Mk/bsd.qt.mk
@@ -301,7 +301,7 @@ _USE_QT4_ONLY= accessible assistant-adp assistantclient codecs-cn codecs-jp \
_USE_QT5_ONLY= buildtools concurrent core graphicaleffects \
paths phonon4 printsupport qdbus qdoc qev qml quick \
- quickcontrols serialport uitools widgets x11extras
+ quickcontrols serialport uitools webchannel widgets x11extras
accessible_PORT= accessibility/${_QT_RELNAME}-accessible
accessible_PATH= ${QT_PLUGINDIR}/accessible/libqtaccessiblewidgets.so
@@ -515,6 +515,9 @@ uic3_PATH= ${QT_BINDIR}/uic3
uitools_PORT= devel/${_QT_RELNAME}-uitools
uitools_PATH= ${QT_LIBDIR}/libQt${_QT_LIBVER}UiTools.a
+webchannel_PORT= www/${_QT_RELNAME}-webchannel
+webchannel_PATH= ${QT_LIBDIR}/libQt${_QT_LIBVER}WebChannel.so
+
webkit_PORT= www/webkit-${_QT_RELNAME}
webkit_PATH= ${QT_LIBDIR}/libQt${_QT_LIBVER}WebKit.so