aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-06-17 20:42:30 +0800
committermat <mat@FreeBSD.org>2016-06-17 20:42:30 +0800
commit53b8609a04d6864bf876cffd9a547d86a34837ff (patch)
tree8f95e0d29536276777e5c8d03bc6210ea396c087 /Mk
parent6221305b82374d59df54952ea15232da83a7d2d2 (diff)
downloadfreebsd-ports-gnome-53b8609a04d6864bf876cffd9a547d86a34837ff.tar.gz
freebsd-ports-gnome-53b8609a04d6864bf876cffd9a547d86a34837ff.tar.zst
freebsd-ports-gnome-53b8609a04d6864bf876cffd9a547d86a34837ff.zip
Remove DO_NADA targets.
No need to have make(1) compute a target order graph for targets that are empty. Sponsored by: Absolight
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.apache.mk5
-rw-r--r--Mk/bsd.autotools.mk38
-rw-r--r--Mk/bsd.gecko.mk7
-rw-r--r--Mk/bsd.ocaml.mk24
-rw-r--r--Mk/bsd.port.mk7
-rw-r--r--Mk/bsd.ruby.mk7
6 files changed, 16 insertions, 72 deletions
diff --git a/Mk/bsd.apache.mk b/Mk/bsd.apache.mk
index 041b91329876..ced4fc792d53 100644
--- a/Mk/bsd.apache.mk
+++ b/Mk/bsd.apache.mk
@@ -487,6 +487,7 @@ PLIST_SUB+= AP_MOD_EN="${AP_MOD_EN}"
.if defined(AP_FAST_BUILD)
.if !target(ap-gen-plist)
+_USES_build+= 490:ap-gen-plist
ap-gen-plist:
.if defined(AP_GENPLIST)
. if !exists(${PLIST})
@@ -496,13 +497,11 @@ ap-gen-plist:
@${ECHO} "@postunexec ${SED} -i '' -E '/LoadModule[[:blank:]]+%%AP_NAME%%_module/d' %D/%%APACHEETCDIR%%/httpd.conf" >> ${PLIST}
@${ECHO} "@postunexec echo \"Don't forget to remove all ${MODULENAME}-related directives in your httpd.conf\"">> ${PLIST}
. endif
-.else
- @${DO_NADA}
.endif
.endif
.if !target(do-build)
-do-build: ap-gen-plist
+do-build:
(cd ${WRKSRC} && ${APXS} -c ${AP_EXTRAS} -o ${MODULENAME}.la ${SRC_FILE})
.endif
diff --git a/Mk/bsd.autotools.mk b/Mk/bsd.autotools.mk
index 8ea75f939848..e4b2d4b9dc3b 100644
--- a/Mk/bsd.autotools.mk
+++ b/Mk/bsd.autotools.mk
@@ -190,52 +190,30 @@ ${var:tu}_ENV+= ${AUTOTOOLS_VARS}
# Make targets
#---------------------------------------------------------------------------
-.if !target(run-autotools)
-.ORDER: run-autotools run-autotools-aclocal \
- run-autotools-autoconf run-autotools-autoheader \
- run-autotools-automake
-
-run-autotools:: run-autotools-aclocal \
- run-autotools-autoconf run-autotools-autoheader \
- run-autotools-automake
-.endif
-
-.if !target(run-autotools-aclocal)
+.if defined(_AUTOTOOL_rule_aclocal) && !target(run-autotools-aclocal)
+_USES_configure+= 460:run-autotools-aclocal
run-autotools-aclocal:
-. if defined(_AUTOTOOL_rule_aclocal)
@(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${ACLOCAL} \
${ACLOCAL_ARGS})
-. else
- @${DO_NADA}
-. endif
.endif
-.if !target(run-autotools-automake)
+.if defined(_AUTOTOOL_rule_automake) && !target(run-autotools-automake)
+_USES_configure+= 461:run-autotools-autoconf
run-autotools-automake:
-. if defined(_AUTOTOOL_rule_automake)
@(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${AUTOMAKE} \
${AUTOMAKE_ARGS})
-. else
- @${DO_NADA}
-. endif
.endif
-.if !target(run-autotools-autoconf)
+.if defined(_AUTOTOOL_rule_autoconf) && !target(run-autotools-autoconf)
+_USES_configure+= 462:run-autotools-autoheader
run-autotools-autoconf:
-. if defined(_AUTOTOOL_rule_autoconf)
@(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${AUTOCONF} \
${AUTOCONF_ARGS})
-. else
- @${DO_NADA}
-. endif
.endif
-.if !target(run-autotools-autoheader)
+.if defined(_AUTOTOOL_rule_autoheader) && !target(run-autotools-autoheader)
+_USES_configure+= 463:run-autotools-automake
run-autotools-autoheader:
-. if defined(_AUTOTOOL_rule_autoheader)
@(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${AUTOHEADER} \
${AUTOHEADER_ARGS})
-. else
- @${DO_NADA}
-. endif
.endif
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index d77ee832c83b..212a58d5597c 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -614,13 +614,6 @@ gecko-do-configure:
pre-install: gecko-moz-pis-pre-install
post-install-script: gecko-create-plist
-gecko-create-plist: port-post-install
-
-.if !target(port-post-install)
-port-post-install:
- @${DO_NADA}
-.endif
-
gecko-create-plist:
# Create the plist
${RM} -f ${PLISTF}
diff --git a/Mk/bsd.ocaml.mk b/Mk/bsd.ocaml.mk
index fa892b502bee..8d7cf2bd9fa8 100644
--- a/Mk/bsd.ocaml.mk
+++ b/Mk/bsd.ocaml.mk
@@ -119,12 +119,6 @@ RUN_DEPENDS+= ${OCAMLC_DEPEND}
PLIST_SUB+= OCAML_SITELIBDIR="${OCAML_SITELIBDIR}"
.endif
-.if defined(USE_OCAML_FINDLIB) || defined(USE_OCAML_LDCONFIG)
-. if !target(post-install-script)
-post-install-script: ocaml-findlib ocaml-ldconfig ocaml-wash
-. endif
-.endif
-
.if defined(USE_OCAML_FINDLIB)
#
# We'll additionally add ocamlfind to RUN_DEPENDS, since
@@ -141,6 +135,7 @@ MAKE_ENV+= OCAMLFIND_DESTDIR="${STAGEDIR}${OCAMLFIND_DESTDIR}" \
# Directories under site-lib to process automatically
#
OCAML_PKGDIRS?= ${PORTNAME}
+_USES_install+= 735:ocaml-findlib
. if !target(ocaml-findlib)
ocaml-findlib:
. for DIR in ${OCAML_PKGDIRS}
@@ -174,6 +169,7 @@ RUN_DEPENDS+= ${OCAMLTK_DEPENDS}
# Directories under PREFIX for appending to ld.conf
#
OCAML_LDLIBS?= ${OCAML_SITELIBDIR}/${PORTNAME}
+_USES_install+= 740:ocaml-ldconfig
. if !target(ocaml-ldconfig)
ocaml-ldconfig:
. for LIB in ${OCAML_LDLIBS}
@@ -186,27 +182,13 @@ ocaml-ldconfig:
.if defined(USE_OCAML_WASH)
. if !target(ocaml-wash)
+_USES_install+= 745:ocaml-wash
ocaml-wash:
# If ld.conf is empty
@${ECHO_CMD} "@postunexec if [ ! -s %D/${OCAML_LDCONF} ]; then ${RM} -f %D/${OCAML_LDCONF}; fi || true" >> ${TMPPLIST}
. endif
.endif
-.if !target(ocaml-findlib)
-ocaml-findlib:
- @${DO_NADA}
-.endif
-
-.if !target(ocaml-ldconfig)
-ocaml-ldconfig:
- @${DO_NADA}
-.endif
-
-.if !target(ocaml-wash)
-ocaml-wash:
- @${DO_NADA}
-.endif
-
.endif #!defined(OCAML_include)
.if defined(_POSTMKINCLUDED)
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 0e3dacf40b87..36e1d94bf091 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3571,11 +3571,6 @@ check-umask:
fi
.endif
-.if !target(install-mtree)
-install-mtree:
- @${DO_NADA}
-.endif
-
.if !target(install-ldconfig-file)
install-ldconfig-file:
. if defined(USE_LDCONFIG) || defined(USE_LDCONFIG32)
@@ -5392,7 +5387,7 @@ _PATCH_SEQ= 050:ask-license 100:patch-message 150:patch-depends \
${_OPTIONS_patch} ${_USES_patch}
_CONFIGURE_DEP= patch
_CONFIGURE_SEQ= 150:build-depends 151:lib-depends 200:configure-message \
- 300:pre-configure 450:pre-configure-script 460:run-autotools \
+ 300:pre-configure 450:pre-configure-script \
490:run-autotools-fixup 500:do-configure 700:post-configure \
850:post-configure-script \
${_OPTIONS_configure} ${_USES_configure}
diff --git a/Mk/bsd.ruby.mk b/Mk/bsd.ruby.mk
index 05a1d0c7080e..93268c3cc4ba 100644
--- a/Mk/bsd.ruby.mk
+++ b/Mk/bsd.ruby.mk
@@ -446,18 +446,15 @@ RUBY_RD_HTML_FILES= ${RUBY_RD_FILES:S/.rb$//:S/.rd././:S/.rd$//:S/$/.html/}
PLIST_SUB+= RUBY_RD_HTML_FILES=""
-pre-install: ruby-rd-build
-
-ruby-rd-build:
.if !empty(RUBY_RD_FILES)
+_USES_build+= 290:ruby-rd-build
+ruby-rd-build:
@${ECHO_MSG} "===> Generating HTML documents from RD documents"
@cd ${WRKSRC}; for rd in ${RUBY_RD_FILES}; do \
html=$$(echo $$rd | ${SED} 's/\.rb$$//;s/\.rd\././;s/\.rd$$//').html; \
${ECHO_MSG} "${RUBY_RD2} $$rd > $$html"; \
${RUBY_RD2} $$rd > $$html; \
done
-.else
- @${DO_NADA}
.endif
.else