aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authordumbbell <dumbbell@FreeBSD.org>2014-12-23 07:04:17 +0800
committerdumbbell <dumbbell@FreeBSD.org>2014-12-23 07:04:17 +0800
commit5bebe6a62d9ab7796738b8cf47e8cea68cb6f008 (patch)
treec4aafe980f6f5ff7e0903fde047107a9dd8c45d5 /Mk
parent8fed23cf2459f63a11abf55cc9928fe2cf6cea15 (diff)
downloadfreebsd-ports-gnome-5bebe6a62d9ab7796738b8cf47e8cea68cb6f008.tar.gz
freebsd-ports-gnome-5bebe6a62d9ab7796738b8cf47e8cea68cb6f008.tar.zst
freebsd-ports-gnome-5bebe6a62d9ab7796738b8cf47e8cea68cb6f008.zip
Final removal of WITH_NEW_XORG
This knob was turned on for all version of FreeBSD in r369875 (2014-10-03) and officially deprecated. Since then, it was gradually removed from many ports when they needed an update. x11-servers/xorg-server was the last major user of this knob. The port was updated to xserver 1.14 in r374982 (2014-12-19). The update got rid of the knob, clearing the path to the final removal. This commit changes ports who were checking for WITH_NEW_XORG and remove its handling from bsd.port.mk. While here, two sanity checks are added to warn user about WITH_KMS and WITH_NEW_XORG which have no effect now. Differential Revision: https://reviews.freebsd.org/D1351 Reviewed by: antoine, bapt, kwm Approved by: portmgr (antoine, bapt), kwm
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk8
-rw-r--r--Mk/bsd.sanity.mk8
2 files changed, 8 insertions, 8 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index bd7b9cca4a61..216271b378e5 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1225,14 +1225,6 @@ _OSVERSION_MAJOR= ${OSVERSION:C/([0-9]?[0-9])([0-9][0-9])[0-9]{3}/\1/}
.error OSREL (${OSREL}) and OSVERSION (${OSVERSION}) do not agree on major version number.
.endif
-# Enable new xorg for FreeBSD versions after Radeon KMS was imported unless
-# WITHOUT_NEW_XORG is set.
-.if !defined(WITHOUT_NEW_XORG)
-WITH_NEW_XORG?= yes
-.else
-.undef WITH_NEW_XORG
-.endif
-
# Only define tools here (for transition period with between pkg tools)
.include "${PORTSDIR}/Mk/bsd.commands.mk"
diff --git a/Mk/bsd.sanity.mk b/Mk/bsd.sanity.mk
index 722b022f8dfa..17a80a2599dc 100644
--- a/Mk/bsd.sanity.mk
+++ b/Mk/bsd.sanity.mk
@@ -7,6 +7,14 @@
WARNING+= "WITHOUT_NLS is deprecated use OPTIONS_UNSET=NLS instead"
.endif
+.if defined(WITH_NEW_XORG) || defined(WITHOUT_NEW_XORG)
+WARNING+= "WITH_NEW_XORG and WITHOUT_NEW_XORG knobs were removed and have no effect"
+.endif
+
+.if defined(WITH_KMS) || defined(WITHOUT_KMS)
+WARNING+= "WITH_KMS was removed and has no effect"
+.endif
+
#.if defined(PKGORIGIN)
#.for _c in ${CATEGORIES}
#_CAT?= ${_c}