aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2013-05-30 09:06:51 +0800
committerbdrewery <bdrewery@FreeBSD.org>2013-05-30 09:06:51 +0800
commit5f31f90dd66322c80732fe422715a3c49c3c4233 (patch)
tree865449cfc7911f0e5049c046a5c8d55460bf57d5 /Mk
parentcf9685cc46ed28c8401db121d8038428bd8260b1 (diff)
downloadfreebsd-ports-gnome-5f31f90dd66322c80732fe422715a3c49c3c4233.tar.gz
freebsd-ports-gnome-5f31f90dd66322c80732fe422715a3c49c3c4233.tar.zst
freebsd-ports-gnome-5f31f90dd66322c80732fe422715a3c49c3c4233.zip
Fix build when WITH_CCACHE_BUILD is set.
The problem is that WITH_CCACHE_BUILD adds PATH to the MAKE_ENV, but the gnustep support sources a GNUStep.sh file that already sets the PATH. Next when env PATH=... is called, it overwrites and losers the gnustep PATH additions. This is a temporary fix until a better solution is found.
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gnustep.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/Mk/bsd.gnustep.mk b/Mk/bsd.gnustep.mk
index fa109251e308..f6f1a0e6ee63 100644
--- a/Mk/bsd.gnustep.mk
+++ b/Mk/bsd.gnustep.mk
@@ -484,6 +484,7 @@ RUN_DEPENDS+= ${GNUSTEP_LOCAL_SERVICES}/${_GNUSTEP_DEP:C/:.*//}.service/${_GNUST
# source GNUstep.sh
#
.if defined(USE_GNUSTEP_CONFIGURE)
+NO_CCACHE= Overrides PATH set from GNUstep.sh
run-autotools::
@${DO_NADA}
@@ -508,6 +509,7 @@ do-configure:
# source GNUstep.sh
#
.if defined(USE_GNUSTEP_BUILD)
+NO_CCACHE= Overrides PATH set from GNUstep.sh
do-build:
.if defined(USE_GNUSTEP_MAKE_DIRS)
.for i in ${USE_GNUSTEP_MAKE_DIRS}