aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2004-07-20 07:25:22 +0800
committerale <ale@FreeBSD.org>2004-07-20 07:25:22 +0800
commit76ac475707bc7d006296a7c6b2d7c3f8b1b9994b (patch)
tree1c83dd5542d84fe1d853eac01b2804288339d596 /Mk
parent1fe3ec4af08fc220d424dd0e6e75dc15d0c6bbbb (diff)
downloadfreebsd-ports-gnome-76ac475707bc7d006296a7c6b2d7c3f8b1b9994b.tar.gz
freebsd-ports-gnome-76ac475707bc7d006296a7c6b2d7c3f8b1b9994b.tar.zst
freebsd-ports-gnome-76ac475707bc7d006296a7c6b2d7c3f8b1b9994b.zip
- Document DEFAULT_PHP_VER and BROKEN_WITH_PHP
- Set them acccordingly in PHP extensions ports (Now I really need some rest, see you tomorrow)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.php.mk10
1 files changed, 9 insertions, 1 deletions
diff --git a/Mk/bsd.php.mk b/Mk/bsd.php.mk
index f76abbe07bbc..231067cd1886 100644
--- a/Mk/bsd.php.mk
+++ b/Mk/bsd.php.mk
@@ -17,6 +17,8 @@
#
# The port can set these options in its Makefile before bsd.ports.pre.mk:
#
+# DEFAULT_PHP_VER=N - Use PHP version N if PHP is not yet installed.
+# BROKEN_WITH_PHP=N - The port doesn't work with PHP version N.
# USE_PHPIZE=yes - Use to build a PHP extension.
# USE_PHPEXT=yes - Use to build, install and register a PHP extension.
# USE_PHP_BUILD=yes - Set PHP also as a build dependency.
@@ -37,9 +39,15 @@ PHP_Include_MAINTAINER= ale@FreeBSD.org
.include "${LOCALBASE}/etc/php.conf"
.endif
-PHP_VER?= 4
+DEFAULT_PHP_VER?= 4
+
+PHP_VER?= ${DEFAULT_PHP_VER}
.if !defined(PHP_EXT_DIR)
+.if ${PHP_VER} == 4
PHP_EXT_DIR= 20020429
+.else
+PHP_EXT_DIR= 20040412
+.endif
.if exists(${LOCALBASE}/include/apache2/httpd.h)
APACHE_MPM!= ${APXS} -q MPM_NAME
.if ${APACHE_MPM} == "worker"