aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2015-04-09 15:49:34 +0800
committerbapt <bapt@FreeBSD.org>2015-04-09 15:49:34 +0800
commit7b77c76ad1dafe1c2f7f4edf8304ffa6b502d739 (patch)
treee1e5410cdab112bb495f10b63cc794a12be2fdc9 /Mk
parentba50e6fa6dadb80fdb12b7fc2be35a67b6867ec7 (diff)
downloadfreebsd-ports-gnome-7b77c76ad1dafe1c2f7f4edf8304ffa6b502d739.tar.gz
freebsd-ports-gnome-7b77c76ad1dafe1c2f7f4edf8304ffa6b502d739.tar.zst
freebsd-ports-gnome-7b77c76ad1dafe1c2f7f4edf8304ffa6b502d739.zip
Remove USE_GNUSTEP from bsd.port.mk
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Scripts/actual-package-depends.sh1
-rw-r--r--Mk/bsd.port.mk8
2 files changed, 1 insertions, 8 deletions
diff --git a/Mk/Scripts/actual-package-depends.sh b/Mk/Scripts/actual-package-depends.sh
index b63e70535afc..c4b58601e438 100644
--- a/Mk/Scripts/actual-package-depends.sh
+++ b/Mk/Scripts/actual-package-depends.sh
@@ -48,6 +48,7 @@ absolute_path() {
find_dep() {
pattern=$1
+ echo $pattern >&2
case ${pattern} in
*\>*|*\<*|*=*)
${PKG_BIN} info -Eg "${pattern}" 2>/dev/null
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 46fbb1f2afe6..b1e171b86e47 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -389,10 +389,6 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# USE_RUBY - If set, this port relies on the Ruby language.
# Implies inclusion of bsd.ruby.mk. (Also see
# that file for more information on USE_RUBY_*).
-# USE_GNUSTEP - If set, this port relies on the GNUstep system.
-# Implies the inclusion of bsd.gnustep.mk.
-# (Also see that file for more information on
-# USE_GNUSTEP_*).
##
# USE_GECKO - If set, this port uses the Gecko/Mozilla product.
# See bsd.gecko.mk for more details.
@@ -1373,10 +1369,6 @@ PKGCOMPATDIR?= ${LOCALBASE}/lib/compat/pkg
.include "${PORTSDIR}/Mk/bsd.emacs.mk"
.endif
-.if defined(USE_GNUSTEP)
-.include "${PORTSDIR}/Mk/bsd.gnustep.mk"
-.endif
-
.if defined(USE_PHP)
.include "${PORTSDIR}/Mk/bsd.php.mk"
.endif