aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2010-08-15 08:35:52 +0800
committertota <tota@FreeBSD.org>2010-08-15 08:35:52 +0800
commit8a3497b0663edf961bd7491f0056dba0927ee223 (patch)
tree5302c3eb77edcdd1f763a665cb584e52516fee65 /Mk
parente5757e8403c81a5700590cf5430aa740754b567d (diff)
downloadfreebsd-ports-gnome-8a3497b0663edf961bd7491f0056dba0927ee223.tar.gz
freebsd-ports-gnome-8a3497b0663edf961bd7491f0056dba0927ee223.tar.zst
freebsd-ports-gnome-8a3497b0663edf961bd7491f0056dba0927ee223.zip
- Add a new knob R_MOD_AUTOPLIST, which allows the packing list
for most R-cran ports to be generated automatically. Inspired by: RUBYGEM_AUTOPLIST knob Submitted by: tota Approved by: wen
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.cran.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/Mk/bsd.cran.mk b/Mk/bsd.cran.mk
index 753ccdbfe5e8..229104978c7d 100644
--- a/Mk/bsd.cran.mk
+++ b/Mk/bsd.cran.mk
@@ -26,3 +26,13 @@ do-install:
@cd ${WRKDIR} && ${R_INS} ${PORTNAME}
.endif
+.if defined(R_MOD) && defined(R_MOD_AUTOPLIST)
+.if !target(post-install-script)
+post-install-script:
+ @${FIND} -ds ${PREFIX}/${R_MOD_DIR} -type f -print | ${SED} -E -e \
+ 's,^${PREFIX}/?,,' > ${TMPPLIST}
+ @${FIND} -ds ${PREFIX}/${R_MOD_DIR} -type d -print | ${SED} -E -e \
+ 's,^${PREFIX}/?,@dirrm ,' >> ${TMPPLIST}
+.endif
+.endif
+