aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2017-04-30 19:07:42 +0800
committertcberner <tcberner@FreeBSD.org>2017-04-30 19:07:42 +0800
commit99bd597a4e63c2c60ac873268ce52ef308d07f9f (patch)
tree85f9e60b7d42af53402d5349c84590b26212dfea /Mk
parent08d9d023d297ccb0c3881c6955965b5c9e2a6ad9 (diff)
downloadfreebsd-ports-gnome-99bd597a4e63c2c60ac873268ce52ef308d07f9f.tar.gz
freebsd-ports-gnome-99bd597a4e63c2c60ac873268ce52ef308d07f9f.tar.zst
freebsd-ports-gnome-99bd597a4e63c2c60ac873268ce52ef308d07f9f.zip
Extend grantlee.mk with another PLIST_SUB.
Grantlee5 appends library names of plugins with a letter 'd' when in debug mode. Provide a PLIST_SUB with said suffix. Approved by: rakuco (mentor)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/grantlee.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/Mk/Uses/grantlee.mk b/Mk/Uses/grantlee.mk
index ca68cd4b44fc..edd8cf8907dd 100644
--- a/Mk/Uses/grantlee.mk
+++ b/Mk/Uses/grantlee.mk
@@ -19,6 +19,10 @@
# Subs:
# GRANTLEE_VERSION_FULL - full version of the chosen grantlee
# GRANTLEE_VERSION_SHORT - short version of the chosen grantlee
+# GRANTLEE_DEBUG_SUFFIX - a suffix to the library name depending
+# the buildtype (WITH_DEBUG) that gets
+# appended to library names of plugins
+# for grantlee5.
#
# Further it will also append the proper LIB_DEPENDS line.
#
@@ -63,4 +67,13 @@ LIB_DEPENDS+= ${GRANTLEE${_grantlee_version}_LIB_DEPEND}
PLIST_SUB+= GRANTLEE_VERSION_FULL=${GRANTLEE_VERSION} \
GRANTLEE_VERSION_SHORT=${GRANTLEE_VERSION:R}
+# GrantleeMacros.cmake provides grantlee_adjust_plugin_name() which appends a
+# letter 'd' to the library name in Debug mode. Provide a PLIST_SUB which can be
+# appended in the plist.
+. if defined(WITH_DEBUG)
+PLIST_SUB+= GRANTLEE_DEBUG_SUFFIX=d
+. else
+PLIST_SUB+= GRANTLEE_DEBUG_SUFFIX=
+. endif
+
.endif