aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbeat <beat@FreeBSD.org>2011-03-22 23:26:35 +0800
committerbeat <beat@FreeBSD.org>2011-03-22 23:26:35 +0800
commita16ceaa46460540c65e687d4e477eaa3437b1016 (patch)
tree2619500082f1d97282471f1704edc5c3105883dc /Mk
parent7c804fa6bacbaa0c2872ec8913be838c054af254 (diff)
downloadfreebsd-ports-gnome-a16ceaa46460540c65e687d4e477eaa3437b1016.tar.gz
freebsd-ports-gnome-a16ceaa46460540c65e687d4e477eaa3437b1016.tar.zst
freebsd-ports-gnome-a16ceaa46460540c65e687d4e477eaa3437b1016.zip
- Add Firefox 4.0 and make Firefox 4.0 the default version.
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gecko.mk16
1 files changed, 9 insertions, 7 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 706f25ccf2df..9f25369be23f 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -177,9 +177,9 @@ Gecko_Pre_Include= bsd.gecko.mk
# is given by the maintainer via the port or by the
# user via defined variable try to find the highest
# stable installed version.
-# Available values: yes 36+ 35+ 36 35
+# Available values: yes 40+ 36+ 35+ 40 36 35
# NOTE:
-# default value 36 is used in case of USE_FIREFOX=yes
+# default value 40 is used in case of USE_FIREFOX=yes
#
# USE_FIREFOX_BUILD Add buildtime dependency on Firefox.
# Available values: see USE_FIREFOX
@@ -218,13 +218,14 @@ USE_FIREFOX:= ${USE_FIREFOX_BUILD}
_FIREFOX_BUILD_DEPENDS= yes
.endif
-_FIREFOX_DEFAULT_VERSION= 36
-_FIREFOX_VERSIONS= 36 35
-_FIREFOX_RANGE_VERSIONS= 36+ 35+
+_FIREFOX_DEFAULT_VERSION= 40
+_FIREFOX_VERSIONS= 40 36 35
+_FIREFOX_RANGE_VERSIONS= 40+ 36+ 35+
# For specifying [36, 35, ..]+
_FIREFOX_35P= 35 ${_FIREFOX_36P}
-_FIREFOX_36P= 36
+_FIREFOX_36P= 36 ${_FIREFOX_40P}
+_FIREFOX_40P= 40
# Set the default Firefox version and check if USE_FIREFOX=yes was given
.if ${USE_FIREFOX} == "yes"
@@ -268,7 +269,8 @@ IGNORE= cannot install: unknown Firefox version: firefox-${USE_FIREFOX:C/([0-9
.endif
# Dependence lines for different Firefox versions
-36_DEPENDS= ${LOCALBASE}/lib/firefox3/firefox:${PORTSDIR}/www/firefox
+40_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox
+36_DEPENDS= ${LOCALBASE}/lib/firefox3/firefox:${PORTSDIR}/www/firefox36
35_DEPENDS= ${LOCALBASE}/lib/firefox3/firefox:${PORTSDIR}/www/firefox35
# Add dependencies