aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-11-02 09:42:30 +0800
committerjbeich <jbeich@FreeBSD.org>2016-11-02 09:42:30 +0800
commita84a2bdb7ce4d76acf7dd744abd2439154426914 (patch)
tree171dc9211a3eac82863466179ee9da413dd65f85 /Mk
parent9e0eb3b3fdda12206da60f73d0c2e0bf1c27d090 (diff)
downloadfreebsd-ports-gnome-a84a2bdb7ce4d76acf7dd744abd2439154426914.tar.gz
freebsd-ports-gnome-a84a2bdb7ce4d76acf7dd744abd2439154426914.tar.zst
freebsd-ports-gnome-a84a2bdb7ce4d76acf7dd744abd2439154426914.zip
www/firefox: update to 50.0 (rc1)
More candidates are likely to come before the official announcement (aka the rush hour) scheduled on 2016-11-15. This one intended to pick up upstream security fixes earlier while looking for downstream regressions. Changes: https://www.mozilla.org/firefox/50.0/releasenotes/ Security: d1853110-07f4-4645-895b-6fd462ad0589 MFH: 2016Q4 (piling up)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/gecko.mk4
-rw-r--r--Mk/bsd.gecko.mk13
2 files changed, 10 insertions, 7 deletions
diff --git a/Mk/Uses/gecko.mk b/Mk/Uses/gecko.mk
index 0fe851d03304..d7c236b90e50 100644
--- a/Mk/Uses/gecko.mk
+++ b/Mk/Uses/gecko.mk
@@ -37,12 +37,12 @@ RUN_DEPENDS+= libxul>=45:www/libxul
.elif ${gecko_ARGS:Mfirefox}
_GECKO_DEFAULT_VERSION= 45
-_GECKO_VERSIONS= 45 49
+_GECKO_VERSIONS= 45 50
_GECKO_TYPE= firefox
# Dependence lines for different Firefox versions
45_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:www/firefox-esr
-49_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:www/firefox
+50_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:www/firefox
.if exists(${LOCALBASE}/bin/firefox)
_GECKO_INSTALLED_VER!= ${LOCALBASE}/bin/firefox --version 2>/dev/null
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index c751110dd62a..50ce2b92c44a 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -85,7 +85,7 @@ MOZILLA_VER?= ${PORTVERSION}
MOZILLA_BIN?= ${PORTNAME}-bin
MOZILLA_EXEC_NAME?=${MOZILLA}
MOZ_RPATH?= ${MOZILLA}
-USES+= cpe compiler:c++11-lang gmake iconv perl5 pkgconfig \
+USES+= cpe gmake iconv perl5 pkgconfig \
python:2.7,build desktop-file-utils
CPE_VENDOR?=mozilla
USE_PERL5= build
@@ -95,10 +95,13 @@ USE_XORG= x11 xcomposite xdamage xext xfixes xrender xt
BUNDLE_LIBS= yes
.endif
-# call to implicitly-deleted copy constructor of 'mozilla::WidevineVideoFrame'
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000019 && ${MOZILLA_VER:R:R} >= 49
-# XXX USES=compiler:c++11-lib cannot be used due to ports/208538
-USE_GCC= 5+
+.if ${MOZILLA_VER:R:R} >= 49
+USES+= compiler:c++14-lang
+FAVORITE_COMPILER= ${COMPILER_TYPE} # c++14-lib
+CPPFLAGS+= -D_GLIBCXX_USE_C99 -D_GLIBCXX_USE_C99_MATH_TR1 \
+ -D_DECLARE_C99_LDBL_MATH # XXX ports/193528
+.else
+USES+= compiler:c++11-lang
.endif
MOZILLA_SUFX?= none