aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-09-25 23:18:27 +0800
committertijl <tijl@FreeBSD.org>2014-09-25 23:18:27 +0800
commitb20f32bb38994e1bb5de05cecc229f10659e0f49 (patch)
treec350c4abc20ce22bda0b7dba0636816742669bc8 /Mk
parent20be128769eb36776631a3639656f9528820a14c (diff)
downloadfreebsd-ports-gnome-b20f32bb38994e1bb5de05cecc229f10659e0f49.tar.gz
freebsd-ports-gnome-b20f32bb38994e1bb5de05cecc229f10659e0f49.tar.zst
freebsd-ports-gnome-b20f32bb38994e1bb5de05cecc229f10659e0f49.zip
- Set CPPFLAGS and LIBS in a number of ports so configure can find libintl.h
and libintl.so. This fixes a problem where DATADIRNAME gets an incorrect value which causes locale files to be installed in the wrong place. - The only configure checks that still need to be patched are related to intltool so move DATADIRNAME patching from USES=pathfix to USE_GNOME=intlhack. - games/klavaro: remove excessive dependencies - japanese/libskk: add INSTALL_TARGET=install-strip - math/libqalculate: add INSTALL_TARGET=install-strip and remove pthread patching - multimedia/freetuxtv: remove excessive dependencies - science/gramps: fix shared-mime-info use Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/pathfix.mk5
-rw-r--r--Mk/bsd.gnome.mk12
2 files changed, 8 insertions, 9 deletions
diff --git a/Mk/Uses/pathfix.mk b/Mk/Uses/pathfix.mk
index f8762a2ceaf3..1a675d6eebc1 100644
--- a/Mk/Uses/pathfix.mk
+++ b/Mk/Uses/pathfix.mk
@@ -28,9 +28,6 @@ pathfix:
s|[(]datadir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g ; \
s|[(]prefix[)]/lib/pkgconfig|(prefix)/libdata/pkgconfig|g ; \
s|[$$][(]localstatedir[)]/scrollkeeper|${SCROLLKEEPER_DIR}|g ; \
- s|[(]libdir[)]/bonobo/servers|(prefix)/libdata/bonobo/servers|g' ; \
- ${FIND} ${WRKSRC} -name "configure" -type f | ${XARGS} ${REINPLACE_CMD} -e \
- 's|DATADIRNAME=lib|DATADIRNAME=share|g ; \
- s|{libdir}/locale|{prefix}/share/locale|g'
+ s|[(]libdir[)]/bonobo/servers|(prefix)/libdata/bonobo/servers|g'
.endif
diff --git a/Mk/bsd.gnome.mk b/Mk/bsd.gnome.mk
index a371357b6b4a..53474900fff0 100644
--- a/Mk/bsd.gnome.mk
+++ b/Mk/bsd.gnome.mk
@@ -477,11 +477,13 @@ pygnome2_USE_GNOME_IMPL=libgnomeui pygtk2
intltool_DETECT= ${LOCALBASE}/bin/intltool-extract
intltool_BUILD_DEPENDS= ${intltool_DETECT}:${PORTSDIR}/textproc/intltool
-intlhack_PRE_PATCH= ${FIND} ${WRKSRC} -name "intltool-merge.in" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|mkdir $$lang or|mkdir $$lang, 0777 or| ; \
- s|^push @INC, "/.*|push @INC, "${LOCALBASE}/share/intltool";| ; \
- s|/usr/bin/iconv|${ICONV_CMD}|g ; \
- s|unpack *[(]'"'"'U\*'"'"'|unpack ('"'"'C*'"'"'|'
+intlhack_PRE_PATCH= ${FIND} ${WRKSRC} -name "intltool-merge.in" | ${XARGS} ${REINPLACE_CMD} \
+ 's|mkdir $$lang or|mkdir $$lang, 0777 or| ; \
+ s|^push @INC, "/.*|push @INC, "${LOCALBASE}/share/intltool";| ; \
+ s|/usr/bin/iconv|${ICONV_CMD}|g ; \
+ s|unpack *[(]'"'"'U\*'"'"'|unpack ('"'"'C*'"'"'|' ; \
+ ${FIND} ${WRKSRC} -name configure | ${XARGS} ${REINPLACE_CMD} \
+ 's/DATADIRNAME=lib/DATADIRNAME=share/'
intlhack_USE_GNOME_IMPL=intltool
gtkhtml3_LIB_DEPENDS= libgtkhtml-3.14.so:${PORTSDIR}/www/gtkhtml3