aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-06-10 20:14:12 +0800
committermat <mat@FreeBSD.org>2014-06-10 20:14:12 +0800
commitd4ba2ee310de35fc89a3aa0df9bd3994df0e1c06 (patch)
treeaeafd6b72a8d3be86af00681d166956acc8e815f /Mk
parentca7b30fe9e4d4f2f6cb72fab91b3b414edba4b52 (diff)
downloadfreebsd-ports-gnome-d4ba2ee310de35fc89a3aa0df9bd3994df0e1c06.tar.gz
freebsd-ports-gnome-d4ba2ee310de35fc89a3aa0df9bd3994df0e1c06.tar.zst
freebsd-ports-gnome-d4ba2ee310de35fc89a3aa0df9bd3994df0e1c06.zip
Remove all the bootstrap files (.bs) from the plists.
Starting with perl 5.20, they're not installed any more if empty, and on FreeBSD, they're (always ?) empty. PR: 190681 Submitted by: mat Exp-Run by: antoine Sponsored by: Absolight
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/perl5.mk8
-rw-r--r--Mk/bsd.port.mk6
2 files changed, 8 insertions, 6 deletions
diff --git a/Mk/Uses/perl5.mk b/Mk/Uses/perl5.mk
index a284c68e08ff..7f203804ee35 100644
--- a/Mk/Uses/perl5.mk
+++ b/Mk/Uses/perl5.mk
@@ -264,9 +264,11 @@ fix-packlist::
-@[ -d ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}/${PERL_ARCH}/auto ] && ${FIND} ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}/${PERL_ARCH}/auto -name .packlist -exec ${SED} -i '' 's|^${STAGEDIR}||' '{}' \;
.endif
-.if ${PERL_LEVEL} >= 502000
-fix-plist-perl:
- -@${REINPLACE_CMD} '/\.bs$$/d' ${TMPPLIST}
+# Starting with perl 5.20, the empty bootstrap files are not installed any
+# more. As we don't need them anyway, remove it altogether.
+.if ${PERL_LEVEL} < 502000
+fix-perl-bs:
+ -@${FIND} ${STAGEDIR} -name '*.bs' -size 0 -delete
.endif
.if !target(regression-test)
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index df5f7a3460bd..947c018d1c53 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -6515,7 +6515,7 @@ _STAGE_SUSEQ= create-users-groups do-install \
install-rc-script install-ldconfig-file install-license \
install-desktop-entries add-plist-info add-plist-docs \
add-plist-examples add-plist-data add-plist-post \
- move-uniquefiles-plist fix-plist-sequence fix-packlist fix-plist-perl
+ move-uniquefiles-plist fix-plist-sequence fix-packlist fix-perl-bs
.if defined(DEVELOPER)
_STAGE_SUSEQ+= stage-qa
.endif
@@ -6528,7 +6528,7 @@ _STAGE_SEQ+= create-users-groups do-install \
install-rc-script install-ldconfig-file install-license \
install-desktop-entries add-plist-info add-plist-docs \
add-plist-examples add-plist-data add-plist-post \
- move-uniquefiles-plist fix-plist-sequence fix-packlist fix-plist-perl
+ move-uniquefiles-plist fix-plist-sequence fix-packlist fix-perl-bs
.if defined(DEVELOPER)
_STAGE_SEQ+= stage-qa
.endif
@@ -6562,7 +6562,7 @@ _INSTALL_SUSEQ= check-umask install-mtree pre-su-install \
desktop-file-post-install kmod-post-install shared-mime-post-install webplugin-post-install \
post-install post-install-script add-plist-buildinfo \
add-plist-info add-plist-docs add-plist-examples \
- add-plist-data add-plist-post fix-plist-sequence fix-plist-perl \
+ add-plist-data add-plist-post fix-plist-sequence fix-perl-bs \
compress-man install-ldconfig-file fake-pkg security-check
_PACKAGE_DEP= install
_PACKAGE_SEQ= package-message pre-package pre-package-script \