aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authortheraven <theraven@FreeBSD.org>2015-09-19 18:33:34 +0800
committertheraven <theraven@FreeBSD.org>2015-09-19 18:33:34 +0800
commitf410eb77efeec7636a0a08f7330d4821a1bcd4d0 (patch)
treeda5a3eeed8b9041e9805decaee1098282defef37 /Mk
parent1659ce0cba407df928696251d75c6308bec3077b (diff)
downloadfreebsd-ports-gnome-f410eb77efeec7636a0a08f7330d4821a1bcd4d0.tar.gz
freebsd-ports-gnome-f410eb77efeec7636a0a08f7330d4821a1bcd4d0.tar.zst
freebsd-ports-gnome-f410eb77efeec7636a0a08f7330d4821a1bcd4d0.zip
Make all GNUstep ports install into the System domain so that the Local domain is available for stuff built from source.
Some ports were already installing in the System domain, for these just remove the Makefile lines explicitly specifying the install domain. The rest are installed in the Local domain, remove any overrides, update their pkg-plists and any explicit paths in the Makefiles and then bump port revision. Approved by: bapt (mentor) Differential Revision: https://reviews.freebsd.org/D2977
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/gnustep.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/Mk/Uses/gnustep.mk b/Mk/Uses/gnustep.mk
index 416605ce051c..faaca1f09709 100644
--- a/Mk/Uses/gnustep.mk
+++ b/Mk/Uses/gnustep.mk
@@ -64,6 +64,10 @@ LIB_DEPENDS+= libgnustep-base.so:${PORTSDIR}/lang/gnustep-base
. if ${USE_GNUSTEP:Mbuild}
PATH:= ${GNUSTEP_SYSTEM_TOOLS}:${GNUSTEP_LOCAL_TOOLS}:${PATH}
MAKE_ENV+= PATH="${PATH}" GNUSTEP_MAKEFILES="${GNUSTEP_MAKEFILES}" GNUSTEP_SYSTEM_ROOT="${GNUSTEP_SYSTEM_ROOT}"
+# All GNUstep things installed from ports should be in the System domain.
+# Things installed from source can then freely live in the Local domain without
+# conflicts.
+MAKE_ENV+= GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
CONFIGURE_ENV+= PATH="${PATH}" GNUSTEP_MAKEFILES="${GNUSTEP_MAKEFILES}" GNUSTEP_SYSTEM_ROOT="${GNUSTEP_SYSTEM_ROOT}"
BUILD_DEPENDS+= gnustep-make>0:${PORTSDIR}/devel/gnustep-make
.include "${USESDIR}/objc.mk"