aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2017-04-22 03:36:36 +0800
committerantoine <antoine@FreeBSD.org>2017-04-22 03:36:36 +0800
commitf794ae08e850409b15906dbf30e0e26a2d60da9b (patch)
tree17ed9372e4eba0f20d8ba8123f1e223fdf50028f /Mk
parente3765cd86389f3c6ffdd6ff4de700dff4c6c2399 (diff)
downloadfreebsd-ports-gnome-f794ae08e850409b15906dbf30e0e26a2d60da9b.tar.gz
freebsd-ports-gnome-f794ae08e850409b15906dbf30e0e26a2d60da9b.tar.zst
freebsd-ports-gnome-f794ae08e850409b15906dbf30e0e26a2d60da9b.zip
Use POSIX conformant expressions with grep(1)
PR: 218691 Submitted by: Kyle Evans With hat: portmgr
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 1f3c93fd096e..0515bf8f2eee 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -5013,7 +5013,7 @@ check-desktop-entries:
${ECHO_MSG} "${PKGNAME}: Makefile error: in desktop entry $$entry: field 1 (Name) is empty"; \
exit 1; \
fi; \
- if ${ECHO_CMD} "$$3" | ${GREP} -iq '.\(png\|svg\|xpm\)$$'; then \
+ if ${ECHO_CMD} "$$3" | ${EGREP} -iq '.(png|svg|xpm)$$'; then \
if ! ${ECHO_CMD} "$$3" | ${GREP} -iq '^/'; then \
${ECHO_MSG} "${PKGNAME}: Makefile warning: in desktop entry $$entry: field 3 (Icon) should be either absolute path or icon name without extension if installed icons follow Icon Theme Specification"; \
fi; \