aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2015-10-13 06:19:35 +0800
committerbdrewery <bdrewery@FreeBSD.org>2015-10-13 06:19:35 +0800
commitff84d26c742f1bec280334c115c8e3f3c30346a9 (patch)
treec15068af2727bbae92b401cf229cb1952f3c91ad /Mk
parent972c282cefc2f6340d498c11c21c693194a2409d (diff)
downloadfreebsd-ports-gnome-ff84d26c742f1bec280334c115c8e3f3c30346a9.tar.gz
freebsd-ports-gnome-ff84d26c742f1bec280334c115c8e3f3c30346a9.tar.zst
freebsd-ports-gnome-ff84d26c742f1bec280334c115c8e3f3c30346a9.zip
Move the exported variable assignments to where they are looked-up.
This is so we are less likely to carry around old vars that are no longer needed and to keep logic more coupled. With hat: portmgr
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index e824d9a99783..e37865b3b0ac 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1166,18 +1166,22 @@ MAINTAINER?= ports@FreeBSD.org
.if !defined(ARCH)
ARCH!= ${UNAME} -p
.endif
+_EXPORTED_VARS+= ARCH
# Get the operating system type
.if !defined(OPSYS)
OPSYS!= ${UNAME} -s
.endif
+_EXPORTED_VARS+= OPSYS
.if !defined(UNAMER)
UNAMER!= ${UNAME} -r
.endif
+_EXPORTED_VARS+= UNAMER
# Get the operating system revision
OSREL?= ${UNAMER:C/-.*//}
+_EXPORTED_VARS+= OSREL
# Get __FreeBSD_version
.if !defined(OSVERSION)
@@ -1189,6 +1193,7 @@ OSVERSION!= ${AWK} '/^\#define[[:blank:]]__FreeBSD_version/ {print $$3}' < ${SRC
.error Unable to determine OS version. Either define OSVERSION, install /usr/include/sys/param.h or define SRC_BASE.
.endif
.endif
+_EXPORTED_VARS+= OSVERSION
# Convert OSVERSION to major release number
_OSVERSION_MAJOR= ${OSVERSION:C/([0-9]?[0-9])([0-9][0-9])[0-9]{3}/\1/}
@@ -1215,6 +1220,7 @@ IGNORE= pkg(8) must be version ${MINIMAL_PKG_VERSION} or greater, but you have
.endif
_PKG_CHECKED= 1
.endif
+_EXPORTED_VARS+= _PKG_CHECKED
MASTERDIR?= ${.CURDIR}
@@ -5054,7 +5060,6 @@ ${_t}:
.if !defined(NOPRECIOUSMAKEVARS)
# These won't change, so we can pass them through the environment
-_EXPORTED_VARS= ARCH OPSYS OSREL OSVERSION UNAMER _PKG_CHECKED
.for var in ${_EXPORTED_VARS}
.if empty(.MAKEFLAGS:M${var}=*)
.MAKEFLAGS: ${var}=${${var}:Q}