aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2015-06-05 03:32:29 +0800
committerbapt <bapt@FreeBSD.org>2015-06-05 03:32:29 +0800
commit027ee50c7d920f6fdb6e29869aeb35ff9feacbf0 (patch)
tree5713f183a6ce31b78566609c23aada4ba81793a7 /Mk
parent9fcc5833744bb847ccc8419dd7a669baa2339ef7 (diff)
downloadfreebsd-ports-gnome-027ee50c7d920f6fdb6e29869aeb35ff9feacbf0.tar.gz
freebsd-ports-gnome-027ee50c7d920f6fdb6e29869aeb35ff9feacbf0.tar.zst
freebsd-ports-gnome-027ee50c7d920f6fdb6e29869aeb35ff9feacbf0.zip
Remove NEED_ROOT, the last customer has been modified to be able to properly
package as a regular user USES=fakeroot and USES=uidfix does a better job and is less intrusive and allows to simplify the way we handle the different targets in the framework
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk21
-rw-r--r--Mk/bsd.sanity.mk4
2 files changed, 2 insertions, 23 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index f40c8b67111b..f3652fd09e96 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3921,12 +3921,6 @@ deinstall-all:
.if !target(do-clean)
do-clean:
-.if defined(NEED_ROOT) && ${UID} != 0 && !defined(INSTALL_AS_USER) && exists(${STAGE_COOKIE})
- @${ECHO_MSG} "===> Switching to root credentials for '${.TARGET}' target"
- @cd ${.CURDIR} && \
- ${SU_CMD} "${MAKE} ${.TARGET}"
- @${ECHO_MSG} "===> Returning to user credentials"
-.else
@if [ -d ${WRKDIR} ]; then \
if [ -w ${WRKDIR} ]; then \
${RM} -rf ${WRKDIR}; \
@@ -3935,7 +3929,6 @@ do-clean:
fi; \
fi
.endif
-.endif
.if !target(clean)
clean:
@@ -5923,19 +5916,6 @@ _STAGE_DEP= build
_STAGE_SEQ= stage-message stage-dir run-depends lib-depends apply-slist pre-install generate-plist \
pre-su-install
# ${POST_PLIST} must be after anything that modifies TMPPLIST
-.if defined(NEED_ROOT)
-_STAGE_SUSEQ= create-users-groups do-install \
- kmod-post-install fix-perl-things \
- webplugin-post-install post-install post-install-script \
- move-uniquefiles patch-lafiles post-stage compress-man \
- install-rc-script install-ldconfig-file install-license \
- install-desktop-entries add-plist-info add-plist-docs \
- add-plist-examples add-plist-data add-plist-post \
- move-uniquefiles-plist ${POST_PLIST}
-.if defined(DEVELOPER)
-_STAGE_SUSEQ+= stage-qa
-.endif
-.else
_STAGE_SEQ+= create-users-groups do-install \
kmod-post-install fix-perl-things \
webplugin-post-install post-install post-install-script \
@@ -5947,7 +5927,6 @@ _STAGE_SEQ+= create-users-groups do-install \
.if defined(DEVELOPER)
_STAGE_SEQ+= stage-qa
.endif
-.endif
_INSTALL_DEP= stage
_INSTALL_SEQ= install-message run-depends lib-depends check-already-installed
_INSTALL_SUSEQ= fake-pkg security-check
diff --git a/Mk/bsd.sanity.mk b/Mk/bsd.sanity.mk
index cc427233bf4f..a540bf93a4d8 100644
--- a/Mk/bsd.sanity.mk
+++ b/Mk/bsd.sanity.mk
@@ -155,8 +155,8 @@ SANITY_UNSUPPORTED= USE_OPENAL USE_FAM USE_MAKESELF USE_ZIP USE_LHA USE_CMAKE \
USE_GETTEXT USE_GMAKE USE_SCONS USE_DRUPAL NO_INSTALL_MANPAGES \
INSTALLS_SHLIB USE_PYDISTUTILS PYTHON_CONCURRENT_INSTALL \
PYDISTUTILS_AUTOPLIST PYTHON_PY3K_PLIST_HACK PYDISTUTILS_NOEGGINFO \
- USE_PYTHON_PREFIX USE_BZIP2 USE_XZ USE_PGSQL
-SANITY_DEPRECATED= PYTHON_PKGNAMESUFFIX USE_AUTOTOOLS NEED_ROOT
+ USE_PYTHON_PREFIX USE_BZIP2 USE_XZ USE_PGSQL NEED_ROOT
+SANITY_DEPRECATED= PYTHON_PKGNAMESUFFIX USE_AUTOTOOLS
USE_AUTOTOOLS_ALT= USES=autoreconf and GNU_CONFIGURE=yes
USE_OPENAL_ALT= USES=openal