aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authortz <tz@FreeBSD.org>2017-01-24 19:31:30 +0800
committertz <tz@FreeBSD.org>2017-01-24 19:31:30 +0800
commit260946db9e24cb90fa5f8fdf5a4c50e385082eb6 (patch)
treebb5b0b74b4e9935f226f64dcdd0d9639f966c750 /Mk
parent185182c8b51336f9ed444d265f9142cb16d59c5d (diff)
downloadfreebsd-ports-gnome-260946db9e24cb90fa5f8fdf5a4c50e385082eb6.tar.gz
freebsd-ports-gnome-260946db9e24cb90fa5f8fdf5a4c50e385082eb6.tar.zst
freebsd-ports-gnome-260946db9e24cb90fa5f8fdf5a4c50e385082eb6.zip
Add support for PHP 7.1
Reviewed by: ale, pi, martin@waschbuesch.de, franco@opnsense.org Approved by: ale
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/php.mk10
1 files changed, 7 insertions, 3 deletions
diff --git a/Mk/Uses/php.mk b/Mk/Uses/php.mk
index 240f235bde5a..06877d8a8df4 100644
--- a/Mk/Uses/php.mk
+++ b/Mk/Uses/php.mk
@@ -102,7 +102,10 @@ DEFAULT_PHP_VER?= ${PHP_DEFAULT:S/.//}
# When adding a version, please keep the comment in
# Mk/bsd.default-versions.mk in sync.
PHP_VER?= ${DEFAULT_PHP_VER}
-. if ${PHP_VER} == 70
+. if ${PHP_VER} == 71
+PHP_EXT_DIR= 20160303
+PHP_EXT_INC= pcre spl
+. elif ${PHP_VER} == 70
PHP_EXT_DIR= 20151012
PHP_EXT_INC= pcre spl
. elif ${PHP_VER} == 56
@@ -298,9 +301,10 @@ _USE_PHP_ALL= bcmath bitset bz2 calendar ctype curl dba dom \
# version specific components
_USE_PHP_VER56= ${_USE_PHP_ALL} mssql mysql sybase_ct
_USE_PHP_VER70= ${_USE_PHP_ALL}
+_USE_PHP_VER71= ${_USE_PHP_ALL}
bcmath_DEPENDS= math/php${PHP_VER}-bcmath
-. if ${PHP_VER} == 70
+. if ${PHP_VER} == 70 || ${PHP_VER} == 71
bitset_DEPENDS= math/pecl-bitset
. else
bitset_DEPENDS= math/pecl-bitset2
@@ -325,7 +329,7 @@ iconv_DEPENDS= converters/php${PHP_VER}-iconv
igbinary_DEPENDS= converters/pecl-igbinary
imap_DEPENDS= mail/php${PHP_VER}-imap
interbase_DEPENDS= databases/php${PHP_VER}-interbase
-. if ${PHP_VER} == 70
+. if ${PHP_VER} == 70 || ${PHP_VER} == 71
intl_DEPENDS= devel/php${PHP_VER}-intl
. else
intl_DEPENDS= devel/pecl-intl