aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-04-28 04:29:36 +0800
committertcberner <tcberner@FreeBSD.org>2018-04-28 04:29:36 +0800
commit354f98f41b0ed0dc0d11cf7498c5d78e26192868 (patch)
tree59ff42fd6dd4aeb0189ec1ae805c13207a7bb391 /Mk
parent13c898e0778b5583e1ec2394d413dda1beaf0ab6 (diff)
downloadfreebsd-ports-gnome-354f98f41b0ed0dc0d11cf7498c5d78e26192868.tar.gz
freebsd-ports-gnome-354f98f41b0ed0dc0d11cf7498c5d78e26192868.tar.zst
freebsd-ports-gnome-354f98f41b0ed0dc0d11cf7498c5d78e26192868.zip
Import the KDE Plasma5 ports
This is an import of the Plasma5 ports that we have had in the development repository for quite some time now. Please note: * Plasma5 cannot be installed at the same time as KDE SC4. * Qt5 assumes /etc/localtime to be a symlink to a tz file, not a regular file. * To start plasma5, it is recommended to use something like exec ck-launch-session startkde * Powermanagement and such is not working :-) I would like to thank all the people that have helped test it in the past years. Reviewed by: adridg Differential Revision: https://reviews.freebsd.org/D15096
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/kde.mk143
1 files changed, 140 insertions, 3 deletions
diff --git a/Mk/Uses/kde.mk b/Mk/Uses/kde.mk
index f85adcdfe9e0..8ee6c4751660 100644
--- a/Mk/Uses/kde.mk
+++ b/Mk/Uses/kde.mk
@@ -22,6 +22,7 @@
# it can add, in addition to 'kde' one of the following:
# kde-frameworks: part of frameworks release
# kde-kde4: part of kde4 release
+# kde-plasma: part of plasma release
# this will then set default values for MASTER_SITES and DIST_SUBDIR
# as well as CPE_VENDOR and LICENSE.
#
@@ -65,6 +66,10 @@ KDE4_APPLICATIONS_VERSION?= 15.04.3
KDE4_BRANCH?= stable
# Current KDE desktop.
+KDE_PLASMA_VERSION?= 5.12.4
+KDE_PLASMA_BRANCH?= stable
+
+# Current KDE frameworks.
KDE_FRAMEWORKS_VERSION?= 5.45.0
KDE_FRAMEWORKS_BRANCH?= stable
@@ -94,7 +99,7 @@ KDE_PREFIX= ${LOCALBASE}
# === CATEGORIES HANDLING -- SETTING DEFAULT VALUES ============================
# Doing MASTER_SITES magic based on the category of the port
-_KDE_CATEGORIES_SUPPORTED= kde-applications kde-frameworks kde-kde4
+_KDE_CATEGORIES_SUPPORTED= kde-applications kde-frameworks kde-kde4 kde-plasma
. for cat in ${_KDE_CATEGORIES_SUPPORTED}
. if ${CATEGORIES:M${cat}}
. if !defined(_KDE_CATEGORY)
@@ -142,6 +147,11 @@ PORTDOCS?= HTML/*
PLIST_SUB+= KDE_APPLICATIONS_SHLIB_VER=${KDE_APPLICATIONS_SHLIB_VER}
. endif
DIST_SUBDIR?= KDE/applications/${KDE_APPLICATIONS_VERSION}
+. elif ${_KDE_CATEGORY:Mkde-plasma}
+PORTVERSION?= ${KDE_PLASMA_VERSION}
+PKGNAMEPREFIX?= plasma5-
+MASTER_SITES?= KDE/${KDE_PLASMA_BRANCH}/plasma/${KDE_PLASMA_VERSION}
+DIST_SUBDIR?= KDE/plasma/${KDE_PLASMA_VERSION}
. elif ${_KDE_CATEGORY:Mkde-frameworks}
PORTVERSION?= ${KDE_FRAMEWORKS_VERSION}
PKGNAMEPREFIX?= kf5-
@@ -194,7 +204,8 @@ PLIST_SUB+= KDE4_VERSION="${KDE4_VERSION}" \
KDE4_KDELIBS_VERSION=${KDE4_KDELIBS_VERSION} \
KDE4_NG_KDELIBS_VERSION=${KDE4_KDELIBS_VERSION:S,^4,5,}
. elif ${_KDE_VERSION:M*5*}
-PLIST_SUB+= KDE_FRAMEWORKS_VERSION="${KDE_FRAMEWORKS_VERSION}"
+PLIST_SUB+= KDE_PLASMA_VERSION="${KDE_PLASMA_VERSION}" \
+ KDE_FRAMEWORKS_VERSION="${KDE_FRAMEWORKS_VERSION}"
. endif
# ==============================================================================
@@ -242,7 +253,7 @@ _USE_FRAMEWORKS_TIER2= auth completion crash doctools \
filemetadata kimageformats jobwidgets notifications \
package pty unitconversion
-_USE_FRAMEWORKS_TIER3= activities baloo5 bookmarks configwidgets \
+_USE_FRAMEWORKS_TIER3= activities activities-stats baloo5 bookmarks configwidgets \
designerplugin emoticons globalaccel guiaddons \
iconthemes init kcmutils kdeclarative \
kded kdesu kdewebkit kio newstuff notifyconfig parts \
@@ -264,6 +275,19 @@ _USE_FRAMEWORKS_ALL= ecm \
${_USE_FRAMEWORKS_PORTING} \
${_USE_FRAMEWORKS_EXTRA}
+# List of components of the KDE Plasma distribution.
+_USE_PLASMA_ALL= activitymanagerd breeze breeze-gtk \
+ breeze-kde4 decoration discover drkonqi hotkeys \
+ infocenter kde-cli-tools kde-gtk-config \
+ kdeplasma-addons kgamma5 kmenuedit kscreen \
+ kscreenlocker ksshaskpass ksysguard kwallet-pam \
+ kwayland-integration kwin kwrited libkscreen \
+ libksysguard milou oxygen plasma-desktop \
+ plasma-integration plasma-pa \
+ plasma-sdk plasma-workspace plasma-workspace-wallpapers \
+ polkit-kde-agent-1 powerdevil systemsettings \
+ user-manager
+
# List of components of the KDE PIM distribution (part of applications).
_USE_KDEPIM5_ALL= akonadicontacts akonadiimportwizard akonadimime akonadinotes \
akonadicalendar akonadisearch alarmcalendar \
@@ -277,6 +301,7 @@ _USE_KDEPIM5_ALL= akonadicontacts akonadiimportwizard akonadimime akonadinotes \
mime pimcommon pimtextedit syndication tnef
_USE_KDE5_ALL= ${_USE_FRAMEWORKS_ALL} \
+ ${_USE_PLASMA_ALL} \
${_USE_KDEPIM5_ALL} \
${_USE_KDE_BOTH}
@@ -367,6 +392,9 @@ strigi_LIB= libstreamanalyzer.so.0
activities_PORT= x11/kf5-kactivities
activities_LIB= libKF5Activities.so
+activities-stats_PORT= x11/kf5-kactivities-stats
+activities-stats_LIB= libKF5ActivitiesStats.so
+
apidox_PORT= devel/kf5-kapidox
apidox_PATH= ${KDE_PREFIX}/bin/kapidox_generate
apidox_TYPE= run
@@ -591,6 +619,115 @@ xmlrpcclient_PORT= net/kf5-kxmlrpcclient
xmlrpcclient_LIB= libKF5XmlRpcClient.so
# ====================== end of frameworks components ==========================
+# ====================== plasma components =====================================
+activitymanagerd_PORT= x11/plasma5-kactivitymanagerd
+activitymanagerd_LIB= libkactivitymanagerd_plugin.so
+
+breeze_PORT= x11-themes/plasma5-breeze
+breeze_PATH= ${KDE_PREFIX}/share/QtCurve/Breeze.qtcurve
+
+breeze-gtk_PORT= x11-themes/plasma5-breeze-gtk
+breeze-gtk_PATH= ${KDE_PREFIX}/lib/kconf_update_bin/gtkbreeze5.5
+
+breeze-kde4_PORT= x11-themes/plasma5-breeze-kde4
+breeze-kde4_PATH= ${KDE_PREFIX}/lib/kde4/kstyle_breeze_config.so
+
+decoration_PORT= x11-wm/plasma5-kdecoration
+decoration_LIB= libkdecorations2.so
+
+discover_PORT= sysutils/plasma5-discover
+discover_PATH= ${KDE_PREFIX}/bin/plasma-discover
+
+drkonqi_PORT= sysutils/plasma5-drkonqi
+drkonqi_PATH= ${KDE_PREFIX}/lib/libexec/drkonqi
+
+hotkeys_PORT= devel/plasma5-khotkeys
+hotkeys_LIB= libkhotkeysprivate.so.5
+
+infocenter_PORT= sysutils/plasma5-kinfocenter
+infocenter_PATH= ${KDE_PREFIX}/bin/kinfocenter
+
+kde-cli-tools_PORT= sysutils/plasma5-kde-cli-tools
+kde-cli-tools_PATH= ${KDE_PREFIX}/bin/kcmshell5
+
+kde-gtk-config_PORT= x11-themes/plasma5-kde-gtk-config
+kde-gtk-config_PATH= ${QT_PLUGINDIR}/kcm_kdegtkconfig.so
+
+kdeplasma-addons_PORT= x11-toolkits/plasma5-kdeplasma-addons
+kdeplasma-addons_PATH= ${QT_PLUGINDIR}/kcm_krunner_dictionary.so
+
+kgamma5_PORT= x11/plasma5-kgamma5
+kgamma5_PATH= ${QT_PLUGINDIR}/kcm_kgamma.so
+
+kmenuedit_PORT= sysutils/plasma5-kmenuedit
+kmenuedit_LIB= libkdeinit5_kmenuedit.so
+
+kscreen_PORT= x11/plasma5-kscreen
+kscreen_PATH= ${KDE_PREFIX}/bin/kscreen-console
+
+kscreenlocker_PORT= security/plasma5-kscreenlocker
+kscreenlocker_LIB= libKScreenLocker.so
+
+ksshaskpass_PORT= security/plasma5-ksshaskpass
+ksshaskpass_PATH= ${KDE_PREFIX}/bin/ksshaskpass
+
+ksysguard_PORT= sysutils/plasma5-ksysguard
+ksysguard_PATH= ${KDE_PREFIX}/bin/ksysguard
+
+kwallet-pam_PORT= security/plasma5-kwallet-pam
+kwallet-pam_PATH= ${KDE_PREFIX}/lib/security/pam_kwallet5.so
+
+kwayland-integration_PORT= x11/plasma5-kwayland-integration
+kwayland-integration_PATH= ${QT_PLUGINDIR}/kf5/org.kde.kidletime.platforms/KF5IdleTimeKWaylandPlugin.so
+
+kwin_PORT= x11-wm/plasma5-kwin
+kwin_PATH= ${KDE_PREFIX}/bin/kwin_x11
+
+kwrited_PORT= devel/plasma5-kwrited
+kwrited_PATH= ${QT_PLUGINDIR}/kf5/kded/kwrited.so
+
+libkscreen_PORT= x11/plasma5-libkscreen
+libkscreen_LIB= libKF5Screen.so
+
+libksysguard_PORT= sysutils/plasma5-libksysguard
+libksysguard_LIB= libksgrd.so
+
+milou_PORT= deskutils/plasma5-milou
+milou_LIB= libmilou.so.5
+
+oxygen_PORT= x11-themes/plasma5-oxygen
+oxygen_LIB= liboxygenstyle5.so
+
+plasma-desktop_PORT= x11/plasma5-plasma-desktop
+plasma-desktop_PATH= ${KDE_PREFIX}/bin/krdb
+
+plasma-integration_PORT= x11/plasma5-plasma-integration
+plasma-integration_PATH= ${QT_PLUGINDIR}/platformthemes/KDEPlasmaPlatformTheme.so
+
+plasma-pa_PORT= audio/plasma5-plasma-pa
+plasma-pa_PATH= ${QT_PLUGINDIR}/kcms/kcm_pulseaudio.so
+
+plasma-sdk_PORT= devel/plasma5-plasma-sdk
+plasma-sdk_PATH= ${KDE_PREFIX}/bin/plasmoidviewer
+
+plasma-workspace_PORT= x11/plasma5-plasma-workspace
+plasma-workspace_LIB= libkdeinit5_kcminit.so
+
+plasma-workspace-wallpapers_PORT= x11-themes/plasma5-plasma-workspace-wallpapers
+plasma-workspace-wallpapers_PATH= ${KDE_PREFIX}/share/wallpapers/Autumn/contents/images/1280x1024.jpg
+
+polkit-kde-agent-1_PORT= sysutils/plasma5-polkit-kde-agent-1
+polkit-kde-agent-1_PATH= ${KDE_PREFIX}/lib/libexec/polkit-kde-authentication-agent-1
+
+powerdevil_PORT= sysutils/plasma5-powerdevil
+powerdevil_LIB= libpowerdevilcore.so
+
+systemsettings_PORT= sysutils/plasma5-systemsettings
+systemsettings_PATH= ${KDE_PREFIX}/bin/systemsettings5
+
+user-manager_PORT= sysutils/plasma5-user-manager
+user-manager_PATH= ${QT_PLUGINDIR}/user_manager.so
+# ====================== end of plasma components ==============================
# ====================== pim5 components =======================================
akonadicontacts_PORT= net/akonadi-contacts