aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2016-05-20 06:55:26 +0800
committerbdrewery <bdrewery@FreeBSD.org>2016-05-20 06:55:26 +0800
commit420d4a6a3353db45292c83e4948cbfe526bfcb59 (patch)
tree0da3ef818a59535210aa9c219e6ffdfa5e498349 /Mk
parentf4d962ae4c1b99bf81b3a20bc23832abb02d5384 (diff)
downloadfreebsd-ports-gnome-420d4a6a3353db45292c83e4948cbfe526bfcb59.tar.gz
freebsd-ports-gnome-420d4a6a3353db45292c83e4948cbfe526bfcb59.tar.zst
freebsd-ports-gnome-420d4a6a3353db45292c83e4948cbfe526bfcb59.zip
Re-enable code from r415530 with safer MAKE_ENV support.
PR: D6271 Sponsored by: EMC / Isilon Storage Division
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index c9c9323ef654..dc8768285184 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1641,13 +1641,13 @@ MAKE_ENV+= NO_PIE=yes
# We prefer to pass MK_*=no but it was only supported after a certain
# revision. Passing WITHOUT_* may conflict with a make.conf or src.conf's
# WITH_* value. Note that ports *do* pull in src.conf.
-.if 0 && ((${OSVERSION} >= 903510 && ${OSVERSION} < 1000000) || \
+.if (${OSVERSION} >= 903510 && ${OSVERSION} < 1000000) || \
(${OSVERSION} >= 1003503 && ${OSVERSION} < 1100000) || \
- ${OSVERSION} >= 1100000)
+ ${OSVERSION} >= 1100000
# We will control debug files. Don't let builds that use /usr/share/mk
# split out debug symbols since the plist won't know to expect it.
-MAKE_ARGS+= MK_DEBUG_FILES=no
-MAKE_ARGS+= MK_KERNEL_SYMBOLS=no
+MAKE_ENV+= MK_DEBUG_FILES=no
+MAKE_ENV+= MK_KERNEL_SYMBOLS=no
.else
MAKE_ENV+= WITHOUT_DEBUG_FILES=yes
MAKE_ENV+= WITHOUT_KERNEL_SYMBOLS=yes