aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-06-14 03:55:46 +0800
committerjbeich <jbeich@FreeBSD.org>2017-06-14 03:55:46 +0800
commit55a7e29248ec6f94086709ece6d0b9a93fd9dab2 (patch)
treefe43d1ea5a1fa93e32ee2535ea400e1e61357192 /Mk
parent3096a5b7f114c3efa4417ae135d210915f7b55d1 (diff)
downloadfreebsd-ports-gnome-55a7e29248ec6f94086709ece6d0b9a93fd9dab2.tar.gz
freebsd-ports-gnome-55a7e29248ec6f94086709ece6d0b9a93fd9dab2.tar.zst
freebsd-ports-gnome-55a7e29248ec6f94086709ece6d0b9a93fd9dab2.zip
www/firefox: update to 54.0
Changes: https://www.mozilla.org/firefox/54.0/releasenotes/ PR: 218912 Security: 6cec1b0a-da15-467d-8691-1dea392d4c8d MFH: 2017Q2 (requires r439925)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/gecko.mk4
-rw-r--r--Mk/bsd.gecko.mk6
2 files changed, 7 insertions, 3 deletions
diff --git a/Mk/Uses/gecko.mk b/Mk/Uses/gecko.mk
index 46cc66c66f39..c895b04979de 100644
--- a/Mk/Uses/gecko.mk
+++ b/Mk/Uses/gecko.mk
@@ -37,12 +37,12 @@ RUN_DEPENDS+= libxul>=45:www/libxul
.elif ${gecko_ARGS:Mfirefox}
_GECKO_DEFAULT_VERSION= 52
-_GECKO_VERSIONS= 52 53
+_GECKO_VERSIONS= 52 54
_GECKO_TYPE= firefox
# Dependence lines for different Firefox versions
52_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:www/firefox-esr
-53_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:www/firefox
+54_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:www/firefox
.if exists(${LOCALBASE}/bin/firefox)
_GECKO_INSTALLED_VER!= ${LOCALBASE}/bin/firefox --version 2>/dev/null
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 6660465a4ae5..7884d4e6a27b 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -139,6 +139,7 @@ MOZ_MK_OPTIONS+=MOZ_OBJDIR="${MOZ_OBJDIR}"
LDFLAGS+= -Wl,--as-needed
+.if ${MOZILLA_VER:R:R} < 55
.if ${OPSYS} != DragonFly # XXX xpcshell crash during install
# use jemalloc 3.0.0 (4.0 for firefox 43+) API for stats/tuning
MOZ_EXPORT+= MOZ_JEMALLOC3=1 MOZ_JEMALLOC4=1
@@ -150,6 +151,7 @@ MOZ_OPTIONS+= --enable-jemalloc
. endif
.endif
.endif # !DragonFly
+.endif # Mozilla < 55
# Standard depends
_ALL_DEPENDS= cairo event ffi graphite harfbuzz hunspell icu jpeg nspr nss png pixman soundtouch sqlite vpx
@@ -328,6 +330,7 @@ MOZ_OPTIONS+= --enable-gconf
MOZ_OPTIONS+= --disable-gconf
.endif
+.if ${MOZILLA_VER:R:R} < 55
.if ${PORT_OPTIONS:MGNOMEUI}
BUILD_DEPENDS+= ${libgnomeui_DETECT}:${libgnomeui_LIB_DEPENDS:C/.*://}
USE_GNOME+= libgnomeui:build
@@ -335,6 +338,7 @@ MOZ_OPTIONS+= --enable-gnomeui
.else
MOZ_OPTIONS+= --disable-gnomeui
.endif
+.endif # Mozilla < 55
.if ${PORT_OPTIONS:MLIBPROXY}
LIB_DEPENDS+= libproxy.so:net/libproxy
@@ -389,7 +393,7 @@ post-patch-SNDIO-on:
.endif
.if ${PORT_OPTIONS:MRUST}
-BUILD_DEPENDS+= rustc:${RUST_PORT}
+BUILD_DEPENDS+= rust>=1.15.1:${RUST_PORT}
. if ${MOZILLA_VER:R:R} >= 51
BUILD_DEPENDS+= cargo>=0.16.0:devel/cargo
. endif