aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2011-08-18 18:05:44 +0800
committerale <ale@FreeBSD.org>2011-08-18 18:05:44 +0800
commit5f1a1a865d842cd7c7fa8b7a3d5ac19cc153ad61 (patch)
treee0c105248f0429a4c2e9235dda35f4da0dc4cdc4 /Mk
parent0a56f9701eab856b94d21028d42895f384b1b820 (diff)
downloadfreebsd-ports-gnome-5f1a1a865d842cd7c7fa8b7a3d5ac19cc153ad61.tar.gz
freebsd-ports-gnome-5f1a1a865d842cd7c7fa8b7a3d5ac19cc153ad61.tar.zst
freebsd-ports-gnome-5f1a1a865d842cd7c7fa8b7a3d5ac19cc153ad61.zip
Fix paths for mozilla ports.
Approved by: flo
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gecko.mk16
1 files changed, 10 insertions, 6 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 5c700383ae5a..7bd0d36dce6d 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -236,10 +236,10 @@ USE_FIREFOX= ${_FIREFOX_DEFAULT_VERSION}
.endif
# Setting/finding Firefox version we want.
-.if exists(${LOCALBASE}/bin/firefox3)
-_FIREFOX_VER!= ${LOCALBASE}/bin/firefox3 --version | ${SED} -e 's/Mozilla Firefox \([0-9]\)\.\([0-9]*\).*/\1\2/'
-.elif exists(${LOCALBASE}/bin/firefox)
+.if exists(${LOCALBASE}/bin/firefox)
_FIREFOX_VER!= ${LOCALBASE}/bin/firefox --version | ${SED} -e 's/Mozilla Firefox \([0-9]\)\.\([0-9]*\).*/\1\2/'
+.elif exists(${LOCALBASE}/bin/firefox3)
+_FIREFOX_VER!= ${LOCALBASE}/bin/firefox3 --version | ${SED} -e 's/Mozilla Firefox \([0-9]\)\.\([0-9]*\).*/\1\2/'
.endif
# Check if installed Firefox version matches the wanted one
@@ -311,6 +311,8 @@ USE_SEAMONKEY= ${_SEAMONKEY_DEFAULT_VERSION}
# Setting/finding SeaMonkey version we want.
.if exists(${LOCALBASE}/bin/seamonkey)
_SEAMONKEY_VER!= ${LOCALBASE}/bin/seamonkey --version | ${SED} -e 's/Mozilla SeaMonkey \([0-9]\)\.\([0-9]*\).*/\1\2/'
+.elif exists(${LOCALBASE}/bin/seamonkey2)
+_SEAMONKEY_VER!= ${LOCALBASE}/bin/seamonkey2 --version | ${SED} -e 's/Mozilla SeaMonkey \([0-9]\)\.\([0-9]*\).*/\1\2/'
.endif
# Check if installed SeaMonkey version matches the wanted one
@@ -343,8 +345,8 @@ IGNORE= cannot install: unknown SeaMonkey version: seamonkey-${USE_SEAMONKEY:C
.endif
# Dependence lines for different SeaMonkey versions
-11_DEPENDS= ${LOCALBASE}/lib/seamonkey/seamonkey-bin:${PORTSDIR}/www/seamonkey
-20_DEPENDS= ${LOCALBASE}/lib/seamonkey/seamonkey:${PORTSDIR}/www/seamonkey2
+23_DEPENDS= ${LOCALBASE}/lib/seamonkey/seamonkey:${PORTSDIR}/www/seamonkey
+20_DEPENDS= ${LOCALBASE}/lib/seamonkey2/seamonkey:${PORTSDIR}/www/seamonkey2
# Add dependencies
.if defined(USE_SEAMONKEY)
@@ -382,6 +384,8 @@ USE_THUNDERBIRD= ${_THUNDERBIRD_DEFAULT_VERSION}
# Setting/finding Thunderbird version we want.
.if exists(${LOCALBASE}/bin/thunderbird)
_THUNDERBIRD_VER!= ${LOCALBASE}/bin/thunderbird --version | ${SED} -e 's/ Thunderbird \([0-9]\)\.\([0-9]*\).*/\1\2/'
+.elif exists(${LOCALBASE}/bin/thunderbird3)
+_THUNDERBIRD_VER!= ${LOCALBASE}/bin/thunderbird3 --version | ${SED} -e 's/ Thunderbird \([0-9]\)\.\([0-9]*\).*/\1\2/'
.endif
# Check if installed Thunderbird version matches the wanted one
@@ -415,7 +419,7 @@ IGNORE= cannot install: unknown Thunderbird version: thunderbird-${USE_THUNDER
# Dependence lines for different Thunderbird versions
60_DEPENDS= ${LOCALBASE}/lib/thunderbird/thunderbird:${PORTSDIR}/mail/thunderbird
-31_DEPENDS= ${LOCALBASE}/lib/thunderbird/thunderbird:${PORTSDIR}/mail/thunderbird3
+31_DEPENDS= ${LOCALBASE}/lib/thunderbird3/thunderbird:${PORTSDIR}/mail/thunderbird3
# Add dependencies
.if defined(USE_THUNDERBIRD)