aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2009-04-02 20:58:21 +0800
committerbsam <bsam@FreeBSD.org>2009-04-02 20:58:21 +0800
commit75f40eb040f78b8715adeb893e01c8ed62aa9b9b (patch)
tree17b39111f07d795faea73f8e72eb806081cfab03 /Mk
parent99e1d2f7639cc6cfa4a121ae7059a573124da2a1 (diff)
downloadfreebsd-ports-gnome-75f40eb040f78b8715adeb893e01c8ed62aa9b9b.tar.gz
freebsd-ports-gnome-75f40eb040f78b8715adeb893e01c8ed62aa9b9b.tar.zst
freebsd-ports-gnome-75f40eb040f78b8715adeb893e01c8ed62aa9b9b.zip
Add some sanity checks:
. a check for valid components at USE_LINUX_APPS; . a check if a component is defined for the given linux distro (has apropriate port).
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.linux-apps.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/Mk/bsd.linux-apps.mk b/Mk/bsd.linux-apps.mk
index cbe8d751e242..453cf1a0542f 100644
--- a/Mk/bsd.linux-apps.mk
+++ b/Mk/bsd.linux-apps.mk
@@ -342,6 +342,25 @@ webauth_DEPENDS= gtk2 atk pango fontconfig
# End component definition section
+# Let's check if components from USE_LINUX_APPS exist at _LINUX_APPS_ALL
+. for component in ${USE_LINUX_APPS}
+. if ${_LINUX_APPS_ALL:M${component}}==""
+IGNORE= bsd.linux-apps.mk test failed: Invalid component USE_LINUX_APPS=${component}
+. endif
+. endfor
+
+# Let's check if components from USE_LINUX_APPS have corresponding <app>_DETECT
+# i.e. if a corresponding <app>_FILE defined for given LINUX_DIST_SUFFIX
+. for component in ${USE_LINUX_APPS}
+. if ${${component}_DETECT}==""
+. if defined(${component}${LINUX_DIST_SUFFIX:S/-/_/}_FILE)
+IGNORE= bsd.linux-apps.mk test failed: The component ${component} is empty for LINUX_DIST_SUFFIX=${LINUX_DIST_SUFFIX} (the corresponding variable ${component}${LINUX_DIST_SUFFIX:S/-/_/}_FILE is empty)
+. else
+IGNORE= bsd.linux-apps.mk test failed: The component ${component} is not defined for LINUX_DIST_SUFFIX=${LINUX_DIST_SUFFIX} (the corresponding variable ${component}${LINUX_DIST_SUFFIX:S/-/_/}_FILE is not defined)
+. endif
+. endif
+. endfor
+
# Recursively expand all dependencies for each app at _LINUX_APPS_ALL
. for component in ${_LINUX_APPS_ALL}
. for subcomponent in ${${component}_DEPENDS}