aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2003-01-01 19:45:25 +0800
committerkris <kris@FreeBSD.org>2003-01-01 19:45:25 +0800
commitc1292fa446f4e4d7d7515d8f6ea5f8b748a60644 (patch)
tree3a32edb204b0d340972cdfe7011d6c80d68366da /Mk
parent14493907b69ad21f178037f92b5e80832017c518 (diff)
downloadfreebsd-ports-gnome-c1292fa446f4e4d7d7515d8f6ea5f8b748a60644.tar.gz
freebsd-ports-gnome-c1292fa446f4e4d7d7515d8f6ea5f8b748a60644.tar.zst
freebsd-ports-gnome-c1292fa446f4e4d7d7515d8f6ea5f8b748a60644.zip
Convert a few more uses of INDEX to ${INDEXFILE}
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.subdir.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/Mk/bsd.port.subdir.mk b/Mk/bsd.port.subdir.mk
index 584d5213b5fc..ecb81bad33e5 100644
--- a/Mk/bsd.port.subdir.mk
+++ b/Mk/bsd.port.subdir.mk
@@ -262,15 +262,15 @@ README.html:
-search: ${PORTSDIR}/INDEX
+search: ${PORTSDIR}/${INDEXFILE}
@here=`pwd`; \
cd ${PORTSDIR}; \
top=`pwd -P`; \
there=`echo "$$here/" | sed s%$$top%${PORTSDIR}%`; \
if [ -n "$$key" ]; then \
- grep $$there ${PORTSDIR}/INDEX | grep -i "${key}" | awk -F\| '{ printf("Port:\t%s\nPath:\t%s\nInfo:\t%s\nMaint:\t%s\nIndex:\t%s\nB-deps:\t%s\nR-deps:\t%s\n\n", $$1, $$2, $$4, $$6, $$7, $$8, $$9); }'; \
+ grep $$there ${PORTSDIR}/${INDEXFILE} | grep -i "${key}" | awk -F\| '{ printf("Port:\t%s\nPath:\t%s\nInfo:\t%s\nMaint:\t%s\nIndex:\t%s\nB-deps:\t%s\nR-deps:\t%s\n\n", $$1, $$2, $$4, $$6, $$7, $$8, $$9); }'; \
elif [ $$name ]; then \
- grep $$there ${PORTSDIR}/INDEX | grep -i "^[^|]*${name}[^|]*|" | awk -F\| '{ printf("Port:\t%s\nPath:\t%s\nInfo:\t%s\nMaint:\t%s\nIndex:\t%s\nB-deps:\t%s\nR-deps:\t%s\n\n", $$1, $$2, $$4, $$6, $$7, $$8, $$9); }'; \
+ grep $$there ${PORTSDIR}/${INDEXFILE} | grep -i "^[^|]*${name}[^|]*|" | awk -F\| '{ printf("Port:\t%s\nPath:\t%s\nInfo:\t%s\nMaint:\t%s\nIndex:\t%s\nB-deps:\t%s\nR-deps:\t%s\n\n", $$1, $$2, $$4, $$6, $$7, $$8, $$9); }'; \
else \
echo "The search target requires a keyword parameter or name parameter,"; \
echo "e.g.: \"make search key=somekeyword\""; \