aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-06-10 16:20:25 +0800
committerbapt <bapt@FreeBSD.org>2013-06-10 16:20:25 +0800
commitdd195907301ae92972ea2da41cc396d91730e3b3 (patch)
tree249c9722475cce73cca55f031b859a3306de8871 /Mk
parent4caa98baf637922ed6cc5745c80b4520d83f8316 (diff)
downloadfreebsd-ports-gnome-dd195907301ae92972ea2da41cc396d91730e3b3.tar.gz
freebsd-ports-gnome-dd195907301ae92972ea2da41cc396d91730e3b3.tar.zst
freebsd-ports-gnome-dd195907301ae92972ea2da41cc396d91730e3b3.zip
Partial revert of r320440 some things has been committed that shouldn't have yet
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gstreamer.mk2
-rw-r--r--Mk/bsd.options.mk70
2 files changed, 28 insertions, 44 deletions
diff --git a/Mk/bsd.gstreamer.mk b/Mk/bsd.gstreamer.mk
index f00e58739969..ab29ae2cbb07 100644
--- a/Mk/bsd.gstreamer.mk
+++ b/Mk/bsd.gstreamer.mk
@@ -60,8 +60,6 @@ GST1_MINOR_VERSION= .0
GST1_SHLIB_VERSION= 0
GST1_MINIMAL_VERSION= .5
-MAKE_ENV+= GI_SCANNER_DISABLE_CACHE=yes
-
#
# missing base: alsa ivorbisdec
# missing good: pulseaudio(need newer pulse version)
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index 7fbeb040f866..07871c3697c0 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -49,7 +49,9 @@
.if !defined(OPTIONSMKINCLUDED)
OPTIONSMKINCLUDED= bsd.options.mk
+OPTIONS_NAME?= ${PKGORIGIN:S/\//_/}
OPTIONSFILE?= ${PORT_DBDIR}/${UNIQUENAME}/options
+OPTIONS_FILE?= ${PORT_DBDIR}/${OPTIONS_NAME}/options
#ALL_OPTIONS= DOCS \
# NLS
@@ -176,6 +178,7 @@ PORT_OPTIONS:= ${PORT_OPTIONS:O:u}
PORT_OPTIONS:= ${PORT_OPTIONS:N${opt}}
. endfor
+# XXX To remove once UNIQUENAME will be removed
## Set the options specified per-port (set by user in make.conf)
. for opt in ${${UNIQUENAME}_SET}
. if !empty(COMPLETE_OPTIONS_LIST:M${opt})
@@ -188,7 +191,22 @@ PORT_OPTIONS:= ${PORT_OPTIONS:O:u}
. for opt in ${${UNIQUENAME}_UNSET}
PORT_OPTIONS:= ${PORT_OPTIONS:N${opt}}
. endfor
+# XXX To remove once UNIQUENAME will be removed
+## Set the options specified per-port (set by user in make.conf)
+. for opt in ${${OPTIONS_NAME}_SET}
+. if !empty(COMPLETE_OPTIONS_LIST:M${opt})
+PORT_OPTIONS+= ${opt}
+. endif
+. endfor
+PORT_OPTIONS:= ${PORT_OPTIONS:O:u}
+
+## Unset the options excluded per-port (set by user in make.conf)
+. for opt in ${${OPTIONS_NAME}_UNSET}
+PORT_OPTIONS:= ${PORT_OPTIONS:N${opt}}
+. endfor
+
+# XXX to remove once UNIQUENAME is removed
## options files (from dialog)
. if exists(${OPTIONSFILE}) && !make(rmconfig)
. include "${OPTIONSFILE}"
@@ -196,6 +214,15 @@ PORT_OPTIONS:= ${PORT_OPTIONS:N${opt}}
. if exists(${OPTIONSFILE}.local)
. include "${OPTIONSFILE}.local"
. endif
+# XXX to remove once UNIQUENAME is removed
+
+## options files (from dialog)
+. if exists(${OPTIONS_FILE}) && !make(rmconfig)
+. include "${OPTIONS_FILE}"
+. endif
+. if exists(${OPTIONS_FILE}.local)
+. include "${OPTIONS_FILE}.local"
+. endif
### convert WITH and WITHOUT found in make.conf or reloaded from old optionsfile
.for opt in ${ALL_OPTIONS}
@@ -306,51 +333,10 @@ WITH_${opt}:= true
.endif
. undef opt
.endfor
+.endif
###
-.for opt in ${COMPLETE_OPTIONS_LIST}
-# PLIST_SUB
-PLIST_SUB?=
-. if defined(OPTIONS_SUB)
-. if ! ${PLIST_SUB:M${opt}=*}
-. if ${PORT_OPTIONS:M${opt}}
-PLIST_SUB:= ${PLIST_SUB} ${opt}=""
-. else
-PLIST_SUB:= ${PLIST_SUB} ${opt}="@comment "
-. endif
-. endif
-. endif
-
-. if ${PORT_OPTIONS:M${opt}}
-. if defined(${opt}_CONFIGURE_ENABLE)
-CONFIGURE_ARGS+= --enable-${${opt}_CONFIGURE_ENABLE}
-. endif
-. if defined(${opt}_CONFIGURE_ON)
-CONFIGURE_ARGS+= ${${opt}_CONFIGURE_ON}
-. endif
-. for flags in CFLAGS CXXFLAGS LDFLAGS CONFIGURE_ENV MAKE_ENV USES DISTFILES
-. if defined(${opt}_${flags})
-${flags}+= ${${opt}_${flags}}
-. endif
-. endfor
-. for deptype in PKG EXTRACT PATCH FETCH BUILD LIB RUN
-. if defined(${opt}_${deptype}_DEPENDS)
-${deptype}_DEPENDS+= ${${opt}_${deptype}_DEPENDS}
-. endif
-. endfor
-. else
-. if defined(${opt}_CONFIGURE_ENABLE)
-CONFIGURE_ARGS+= --disable-${${opt}_CONFIGURE_ENABLE}
-. endif
-. if defined(${opt}_CONFIGURE_OFF)
-CONFIGURE_ARGS+= ${${opt}_CONFIGURE_OFF}
-. endif
-. endif
-.endfor
-
_OPTIONS_WITHOUT_GLOBALS:= ${COMPLETE_OPTIONS_LIST}
.for opt in ${GLOBAL_OPTIONS}
_OPTIONS_WITHOUT_GLOBALS:= ${_OPTIONS_WITHOUT_GLOBALS:N${opt}}
.endfor
-
-.endif