aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-04-02 22:01:27 +0800
committermiwi <miwi@FreeBSD.org>2013-04-02 22:01:27 +0800
commitec5ac68df194e17347e62431b787b3abf1b0ad80 (patch)
tree800fc7ca0ab0cb4e903963353a4ad64c97d8b00d /Mk
parentef25c7f262a5d65dcb65e00985b99e39e5c5ebfc (diff)
downloadfreebsd-ports-gnome-ec5ac68df194e17347e62431b787b3abf1b0ad80.tar.gz
freebsd-ports-gnome-ec5ac68df194e17347e62431b787b3abf1b0ad80.tar.zst
freebsd-ports-gnome-ec5ac68df194e17347e62431b787b3abf1b0ad80.zip
- Add a workaround for leaky environment's make index (this unbreaks all gecko@ for FreeBSD-8 on pointyhat)
Reported by: pointyhat Tested with: pointyhat/poudriere oked by: flo (gecko@) Submitted by: antoine (thx!) Approved by: portmgr
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gecko.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index b54be8561ffe..b7380380d03b 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -553,15 +553,15 @@ LDFLAGS+= -Wl,-rpath,${PREFIX}/lib/${MOZ_RPATH}
.if ${MOZILLA_VER:R:R} >= 19 || ${MOZILLA:Mseamonkey*}
# prefer clang
-. if ${CC} == "cc" && (exists(/usr/bin/clang) || \
+. if ${CC} == "cc" && (exists(/usr/bin/clang) && ${OSVERSION} >= 900014 || \
exists(${LOCALBASE}/bin/clang))
CC= clang
. endif
-. if ${CXX} == "c++" && (exists(/usr/bin/clang++) || \
+. if ${CXX} == "c++" && (exists(/usr/bin/clang++) && ${OSVERSION} >= 900014 || \
exists(${LOCALBASE}/bin/clang++))
CXX= clang++
. endif
-. if ${CPP} == "cpp" && (exists(/usr/bin/clang-cpp) || \
+. if ${CPP} == "cpp" && (exists(/usr/bin/clang-cpp) && ${OSVERSION} >= 900014 || \
exists(${LOCALBASE}/bin/clang-cpp))
CPP= clang-cpp
. endif