aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2014-06-28 14:59:48 +0800
committermva <mva@FreeBSD.org>2014-06-28 14:59:48 +0800
commit097b34509513c1c158229648b15e89d4b1af2b8c (patch)
tree94b2fddf463bd3827a1696001abe84a01108e61e /Mk
parentda2873ae14a61161d073ff79aa777c1b47b89b6e (diff)
downloadfreebsd-ports-gnome-097b34509513c1c158229648b15e89d4b1af2b8c.tar.gz
freebsd-ports-gnome-097b34509513c1c158229648b15e89d4b1af2b8c.tar.zst
freebsd-ports-gnome-097b34509513c1c158229648b15e89d4b1af2b8c.zip
- Fix PYDISTUTILS_SETUP to use a proper argument list and avoid polluting the
PYDISTUTILS_*_ARGS with wrong flags. PR: 191317 Phabric: D270 Exp-run: antoine With hat: python@
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.python.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index 14e214cb92f9..eeb2b5fc041c 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -548,7 +548,10 @@ post-install: stage-python-compileall
# distutils support
PYSETUP?= setup.py
-PYDISTUTILS_SETUP?= -c "import setuptools; __file__='${PYSETUP}'; exec(compile(open(__file__, 'rb').read().replace(b'\\r\\n', b'\\n'), __file__, 'exec'))"
+PYDISTUTILS_SETUP?= -c \
+ "import sys; import setuptools; \
+ __file__='${PYSETUP}'; sys.argv[0]='${PYSETUP}'; \
+ exec(compile(open(__file__, 'rb').read().replace(b'\\r\\n', b'\\n'), __file__, 'exec'))"
PYDISTUTILS_CONFIGUREARGS?=
PYDISTUTILS_BUILDARGS?=
PYDISTUTILS_INSTALLARGS?= -c -O1 --prefix=${PREFIX}