aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-01-15 19:34:53 +0800
committermat <mat@FreeBSD.org>2018-01-15 19:34:53 +0800
commit1ab24aef54052f3420944a0fc912c72a1eb6f04a (patch)
treeee4f3e79aa5067e7fd7a4c2c7edf12139c496c81 /Mk
parentb9ba9b47b94882915749958689972b4b09f0da86 (diff)
downloadfreebsd-ports-gnome-1ab24aef54052f3420944a0fc912c72a1eb6f04a.tar.gz
freebsd-ports-gnome-1ab24aef54052f3420944a0fc912c72a1eb6f04a.tar.zst
freebsd-ports-gnome-1ab24aef54052f3420944a0fc912c72a1eb6f04a.zip
Fix a bug in USE_GITHUB code where a version with more than one / was
not sanitized properly. Sponsored by: Absolight
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.sites.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/bsd.sites.mk b/Mk/bsd.sites.mk
index 407b045d53c7..96288ba5db72 100644
--- a/Mk/bsd.sites.mk
+++ b/Mk/bsd.sites.mk
@@ -429,7 +429,7 @@ GH_PROJECT:= ${GH_PROJECT_DEFAULT}
GH_TAGNAME:= ${GH_TAGNAME_DEFAULT}
GH_SUBDIR:= ${GH_SUBDIR_DEFAULT}
. if defined(GH_TAGNAME)
-GH_TAGNAME_SANITIZED= ${GH_TAGNAME:S,/,-,}
+GH_TAGNAME_SANITIZED= ${GH_TAGNAME:S,/,-,g}
# GitHub silently converts tags starting with v to not have v in the filename
# and extraction directory. It also replaces + with -.
GH_TAGNAME_EXTRACT= ${GH_TAGNAME_SANITIZED:C/^[vV]([0-9])/\1/:S/+/-/g}