aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2010-06-07 01:17:04 +0800
committergerald <gerald@FreeBSD.org>2010-06-07 01:17:04 +0800
commit1fdbadb053784d01ea2d4512c341daea2721be38 (patch)
treeb8fb9fb8ce7e1ea9bc197c5341137aad756ec367 /Mk
parentf80b55cff85234525eb851a58b90d4384ca31b49 (diff)
downloadfreebsd-ports-gnome-1fdbadb053784d01ea2d4512c341daea2721be38.tar.gz
freebsd-ports-gnome-1fdbadb053784d01ea2d4512c341daea2721be38.tar.zst
freebsd-ports-gnome-1fdbadb053784d01ea2d4512c341daea2721be38.zip
USE_GCC=4.3 is deprecated (and no port uses it anymore). USE_GCC=4.3+
is transparently rewritten to USE_GCC=4.4+ and lang/gcc43 will be disconnected from the USE_GCC infrastructure soon.
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gcc.mk10
1 files changed, 9 insertions, 1 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index f5e46bafdb06..f3e94290d6a1 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -12,7 +12,10 @@
# the version. Note that the Fortran compiler is specified with the
# USE_FORTRAN knob.
#
-# For example:
+# As of 2010-06-06, USE_GCC=4.3 is deprecated and USE_GCC=4.3+ is
+# transparently rewritten to USE_GCC=4.4+.
+#
+# Examples:
# USE_GCC= 4.2+ # port requires GCC 4.2 or later.
# USE_GCC= 4.5 # port requires GCC 4.5.
#
@@ -114,6 +117,11 @@ MAKE_ENV+= F77="${F77}" FC="${FC}" FFLAGS="${FFLAGS}"
.if defined(USE_GCC)
+# USE_GCC=4.3 is deprecated...
+.if ${USE_GCC} == 4.3+
+USE_GCC:=4.4+
+.endif
+
# See if we can use a later version
_USE_GCC:= ${USE_GCC:S/+//}
.if ${USE_GCC} != ${_USE_GCC}