aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2012-08-04 05:23:04 +0800
committergerald <gerald@FreeBSD.org>2012-08-04 05:23:04 +0800
commit28057ecc1c9edade25881a2471620e87e825c6f1 (patch)
treed4f0a8b9cf55576eb93d6b2b5250ed6b8913610f /Mk
parent4c765f059eaf3b36a122fd28873fb92e1a26cc69 (diff)
downloadfreebsd-ports-gnome-28057ecc1c9edade25881a2471620e87e825c6f1.tar.gz
freebsd-ports-gnome-28057ecc1c9edade25881a2471620e87e825c6f1.tar.zst
freebsd-ports-gnome-28057ecc1c9edade25881a2471620e87e825c6f1.zip
Introduce _GCC_RUNTIME, to be used by ports in need of knowing the
run-time directory of the version of GCC in use. As a side effect this fixes the inclusion of said directory into CFLAGS and LDFLAGS (and FFLAGS where applicable). [1] Reported by: Scott Allendorf <scott-allendorf@uiowa.edu> [1]
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gcc.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index 4de739f0877d..72fe92ea9a60 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -189,11 +189,12 @@ CC:= gcc${V}
CXX:= g++${V}
CPP:= cpp${V}
. if ${_USE_GCC} != 3.4
-CFLAGS+= -Wl,-rpath=${LOCALBASE}/lib/gcc${V}
-LDFLAGS+= -Wl,-rpath=${LOCALBASE}/lib/gcc${V}
+_GCC_RUNTIME:= ${LOCALBASE}/lib/gcc${V}
+CFLAGS+= -Wl,-rpath=${_GCC_RUNTIME}
+LDFLAGS+= -Wl,-rpath=${_GCC_RUNTIME}
. if defined (USE_FORTRAN)
. if ${USE_FORTRAN} == yes
-FFLAGS+= -Wl,-rpath=${LOCALBASE}/lib/gcc${V}
+FFLAGS+= -Wl,-rpath=${_GCC_RUNTIME}
. endif
. endif
# The following is for the sakes of some ports which use this without