aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-08-04 17:11:25 +0800
committerbapt <bapt@FreeBSD.org>2014-08-04 17:11:25 +0800
commit29ca14298ef0db26d8ef8810f35a8e8d4368e12f (patch)
tree1e9acf477fa72cf7c888cc484c96bd4f207a487a /Mk
parent95cd0aca7d833ed9707fa1bc2d6528f8ed54c76d (diff)
downloadfreebsd-ports-gnome-29ca14298ef0db26d8ef8810f35a8e8d4368e12f.tar.gz
freebsd-ports-gnome-29ca14298ef0db26d8ef8810f35a8e8d4368e12f.tar.zst
freebsd-ports-gnome-29ca14298ef0db26d8ef8810f35a8e8d4368e12f.zip
Update mozilla ports:
- firefox 31.0 - firefox-esr 24.7.0 - libxul 24.7.0 - seamonkey 2.26.1 - thunderbird 31.0 Among changes: - add workaround for crash with openldap on thunderbird and seamonkey [1] - add crashfix for architectures with strict alignmentment - backport crashfix with system sqlite/nss on firefox-esr and thunderbird - restore hooking jemalloc in sqlite on freebsd 10+ - fix thunderbird build with -jN [2] - respect MAKE_JOBS_NUMBER regardless of kern.smp.cpus [2] - define CPE_URI for nspr/nss and firefox/thunderbird/seamonkey - require recent gstreamer1-libav i386 crashfix - add DTRACE option for use with DTraceToolkit (js_flowtime.d, js_who.d, etc) PR: 165263 [1] PR: 184630 [2] Submitted by: Jan Beich
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/gecko.mk10
-rw-r--r--Mk/bsd.gecko.mk25
2 files changed, 28 insertions, 7 deletions
diff --git a/Mk/Uses/gecko.mk b/Mk/Uses/gecko.mk
index 60261709938c..92df7029c7b2 100644
--- a/Mk/Uses/gecko.mk
+++ b/Mk/Uses/gecko.mk
@@ -39,12 +39,12 @@ RUN_DEPENDS+= libxul>=24:${PORTSDIR}/www/libxul
.elif ${_GECKO_ARGS:Mfirefox}
_GECKO_DEFAULT_VERSION= 24
-_GECKO_VERSIONS= 24 30
+_GECKO_VERSIONS= 24 31
_GECKO_TYPE= firefox
# Dependence lines for different Firefox versions
24_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox-esr
-30_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox
+31_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox
.if exists(${LOCALBASE}/bin/firefox)
_GECKO_INSTALLED_VER!= ${LOCALBASE}/bin/firefox --version 2>/dev/null
@@ -67,8 +67,8 @@ _GECKO_INSTALLED_VER:= ${_GECKO_INSTALLED_VER:M[0-9]*:C/[0-9].([0-9][0-9]).*/\1/
.elif ${_GECKO_ARGS:Mthunderbird}
-_GECKO_DEFAULT_VERSION= 24
-_GECKO_VERSIONS= 24
+_GECKO_DEFAULT_VERSION= 31
+_GECKO_VERSIONS= 31
_GECKO_TYPE= thunderbird
.if exists(${LOCALBASE}/bin/thunderbird)
@@ -77,7 +77,7 @@ _GECKO_INSTALLED_VER:= ${_GECKO_INSTALLED_VER:M[0-9][0-9]*:C/([0-9][0-9]).*/\1/g
.endif
# Dependence lines for different Thunderbird versions
-24_DEPENDS= ${LOCALBASE}/lib/thunderbird/thunderbird:${PORTSDIR}/mail/thunderbird
+31_DEPENDS= ${LOCALBASE}/lib/thunderbird/thunderbird:${PORTSDIR}/mail/thunderbird
.else
IGNORE= Unknown type of gecko dependency you may specify either libxul, firefox, seamonkey or thunderbird
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 4f3f6feaf543..a133e17bee98 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -85,7 +85,8 @@ MOZILLA_VER?= ${PORTVERSION}
MOZILLA_BIN?= ${PORTNAME}-bin
MOZILLA_EXEC_NAME?=${MOZILLA}
MOZ_RPATH?= ${MOZILLA}
-USES+= compiler:c++11-lib gmake iconv perl5 pkgconfig desktop-file-utils
+USES+= cpe compiler:c++11-lib gmake iconv perl5 pkgconfig desktop-file-utils
+CPE_VENDOR?=mozilla
USE_PERL5= build
USE_XORG= xext xrender xt
@@ -185,7 +186,7 @@ pixman_EXTRACT_AFTER_ARGS= --exclude mozilla*/gfx/cairo/libpixman
png_LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
png_MOZ_OPTIONS= --with-system-png=${LOCALBASE}
-png_EXTRACT_AFTER_ARGS= --exclude mozilla*/media/libpng
+#png_EXTRACT_AFTER_ARGS= --exclude mozilla*/media/libpng
.if exists(${FILESDIR}/patch-z-bug517422) || exists(${FILESDIR}/patch-zz-bug517422)
soundtouch_LIB_DEPENDS= libSoundTouch.so:${PORTSDIR}/audio/soundtouch
@@ -394,6 +395,15 @@ STRIP= # ports/184285
MOZ_OPTIONS+= --disable-debug --enable-release
.endif
+.if ${PORT_OPTIONS:MDTRACE}
+. if ${OSVERSION} < 1000510
+BROKEN= dtrace -G crashes with C++ object files
+. endif
+MOZ_OPTIONS+= --enable-dtrace
+LIBS+= -lelf
+STRIP=
+.endif
+
.if ${PORT_OPTIONS:MLOGGING} || ${PORT_OPTIONS:MDEBUG}
MOZ_OPTIONS+= --enable-logging
.else
@@ -420,6 +430,17 @@ MOZ_OPTIONS+= --disable-strip --disable-install-strip
MOZ_OPTIONS+= --enable-strip --enable-install-strip
.endif
+# _MAKE_JOBS is only available after bsd.port.post.mk, thus cannot be
+# used in .mozconfig. And client.mk automatically uses -jN where N
+# is what multiprocessing.cpu_count() returns.
+.if defined(MAKE_JOBS_NUMBER)
+MOZ_MAKE_FLAGS+=-j${MAKE_JOBS_NUMBER}
+.endif
+
+.if defined(MOZ_MAKE_FLAGS)
+MOZ_MK_OPTIONS+=MOZ_MAKE_FLAGS="${MOZ_MAKE_FLAGS}"
+.endif
+
MOZ_SED_ARGS+= -e's|@CPPFLAGS@|${CPPFLAGS}|g' \
-e 's|@CFLAGS@|${CFLAGS}|g' \
-e 's|@LDFLAGS@|${LDFLAGS}|g' \