aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2014-03-05 21:53:51 +0800
committerbdrewery <bdrewery@FreeBSD.org>2014-03-05 21:53:51 +0800
commit3ba6feb55da40d072a0eea7f401fdf0e687d077a (patch)
treed2eb118c33ecbfb069ba04b9ce0b032c6e9905f8 /Mk
parent10c6534318e1f2fb7bef5530c8eded0256f57f5f (diff)
downloadfreebsd-ports-gnome-3ba6feb55da40d072a0eea7f401fdf0e687d077a.tar.gz
freebsd-ports-gnome-3ba6feb55da40d072a0eea7f401fdf0e687d077a.tar.zst
freebsd-ports-gnome-3ba6feb55da40d072a0eea7f401fdf0e687d077a.zip
- Remove redundant WITH_PKGNG checks. bsd.pkgng.mk is only included if
it is defined. With hat: portmgr Discussed with: bapt
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.pkgng.mk28
1 files changed, 9 insertions, 19 deletions
diff --git a/Mk/bsd.pkgng.mk b/Mk/bsd.pkgng.mk
index 2c501d377269..9c19f9895159 100644
--- a/Mk/bsd.pkgng.mk
+++ b/Mk/bsd.pkgng.mk
@@ -136,7 +136,6 @@ fake-pkg: create-manifest
.endif
.endif
-.if defined(WITH_PKGNG)
.if !target(check-build-conflicts)
check-build-conflicts:
.if ( defined(CONFLICTS) || defined(CONFLICTS_BUILD) ) && !defined(DISABLE_CONFLICTS) && !defined(DEFER_CONFLICTS_CHECK)
@@ -228,7 +227,6 @@ check-install-conflicts:
.endif # defined(DEFER_CONFLICTS_CHECK)
.endif
.endif
-.endif
.if !target(do-package)
.if !defined(NO_STAGE)
@@ -248,28 +246,21 @@ do-package: ${TMPPLIST}
${RM} -f ${PACKAGES}/$$cat/${PKGNAMEPREFIX}${PORTNAME}*${PKG_SUFX} ; \
done
@if ${SETENV} FORCE_POST="${_FORCE_POST_PATTERNS}" ${PKG_CREATE} ${PKG_CREATE_ARGS} -o ${PKGREPOSITORY} ${PKGNAME}; then \
- if [ -n "${WITH_PKGNG}" ]; then \
- if [ "${PKGORIGIN}" = "ports-mgmt/pkg" -o "${PKGORIGIN}" = "ports-mgmt/pkg-devel" ]; then \
- if [ ! -d ${PKGLATESTREPOSITORY} ]; then \
- if ! ${MKDIR} ${PKGLATESTREPOSITORY}; then \
- ${ECHO_MSG} "=> Can't create directory ${PKGLATESTREPOSITORY}."; \
- exit 1; \
- fi; \
- fi ; \
- ${LN} -sf ../${PKGREPOSITORYSUBDIR}/${PKGNAME}${PKG_SUFX} ${PKGLATESTFILE} ; \
- fi; \
- else \
- if [ -d ${PACKAGES} ]; then \
- cd ${.CURDIR} && eval ${MAKE} package-links; \
- fi; \
- fi ; \
+ if [ "${PKGORIGIN}" = "ports-mgmt/pkg" -o "${PKGORIGIN}" = "ports-mgmt/pkg-devel" ]; then \
+ if [ ! -d ${PKGLATESTREPOSITORY} ]; then \
+ if ! ${MKDIR} ${PKGLATESTREPOSITORY}; then \
+ ${ECHO_MSG} "=> Can't create directory ${PKGLATESTREPOSITORY}."; \
+ exit 1; \
+ fi; \
+ fi ; \
+ ${LN} -sf ../${PKGREPOSITORYSUBDIR}/${PKGNAME}${PKG_SUFX} ${PKGLATESTFILE} ; \
+ fi; \
else \
cd ${.CURDIR} && eval ${MAKE} delete-package; \
exit 1; \
fi
.endif
-.if defined(WITH_PKGNG)
.if !target(check-already-installed)
.if !defined(NO_PKG_REGISTER) && !defined(FORCE_PKG_REGISTER)
check-already-installed:
@@ -312,6 +303,5 @@ deinstall:
@${RM} -f ${INSTALL_COOKIE} ${PACKAGE_COOKIE}
.endif
.endif
-.endif
.endif # defined(_POSTMKINCLUDED)