aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2011-06-09 16:22:45 +0800
committerbapt <bapt@FreeBSD.org>2011-06-09 16:22:45 +0800
commit67fe5082fac540cf9e5e1745cc054c76635cdc11 (patch)
tree97e35064aa363921a141ffe3ae29a3f07549b664 /Mk
parentdd9ea661ff815b87515cd435d8af461e208bebe0 (diff)
downloadfreebsd-ports-gnome-67fe5082fac540cf9e5e1745cc054c76635cdc11.tar.gz
freebsd-ports-gnome-67fe5082fac540cf9e5e1745cc054c76635cdc11.tar.zst
freebsd-ports-gnome-67fe5082fac540cf9e5e1745cc054c76635cdc11.zip
Fix fetch-urlall-list
Reported by: amdmi3@ (by mail) Approved by: portmgr@ (bapt@, self)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 08b4571a1bb8..9689eb7b4156 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -4858,7 +4858,7 @@ fetch-url-list-int:
fi ; \
for site in `eval $$SORTED_MASTER_SITES_CMD_TMP ${_RANDOMIZE_SITES}`; do \
DIR=${DIST_SUBDIR}; \
- CKSIZE=`${AWK} "/^SIZE \($${DIR:+$$DIR/}$$file\)"'{print $$4}' ${DISTINFO_FILE}`; \
+ CKSIZE=`${AWK} "/^SIZE \($${DIR:+$$DIR/}$$file\)/"'{print $$4}' ${DISTINFO_FILE}`; \
case $${file} in \
*/*) args="-o $${file} $${site}$${file}";; \
*) args=$${site}$${file};; \
@@ -4889,7 +4889,7 @@ fetch-url-list-int:
fi ; \
for site in `eval $$SORTED_PATCH_SITES_CMD_TMP ${_RANDOMIZE_SITES}`; do \
DIR=${DIST_SUBDIR}; \
- CKSIZE=`${AWK} "/^SIZE \($${DIR:+$$DIR/}$$file\)"'{print $$4}' ${DISTINFO_FILE}`; \
+ CKSIZE=`${AWK} "/^SIZE \($${DIR:+$$DIR/}$$file\)/"'{print $$4}' ${DISTINFO_FILE}`; \
case $${file} in \
*/*) args="-o $${file} $${site}$${file}";; \
*) args=$${site}$${file};; \