aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2010-09-15 18:54:46 +0800
committerpav <pav@FreeBSD.org>2010-09-15 18:54:46 +0800
commit891b0e6ad2703b48f59903e0f3d24f3ff2f77fec (patch)
tree0992a608945751b58f065850fcc90ad96969b4d6 /Mk
parente17e484b1d42e39ce81217962f1de3d6286958a7 (diff)
downloadfreebsd-ports-gnome-891b0e6ad2703b48f59903e0f3d24f3ff2f77fec.tar.gz
freebsd-ports-gnome-891b0e6ad2703b48f59903e0f3d24f3ff2f77fec.tar.zst
freebsd-ports-gnome-891b0e6ad2703b48f59903e0f3d24f3ff2f77fec.zip
- Add USE_BINUTILS knob that makes the build process use binutils from port
instead of the binutils in base PR: ports/149955 Submitted by: bf
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 88b098954210..ffd0233a5442 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -312,6 +312,7 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# USE_GCC - If set, this port requires this version of gcc, either in
# the system or installed from a port.
# USE_CSTD - Override the default C language standard (gnu89, gnu99)
+# USE_BINUTILS - Use binutils suite from port instead of the version in base.
# USE_GMAKE - If set, this port uses gmake.
# GMAKE - Set to path of GNU make if not in $PATH.
# Default: gmake
@@ -1734,6 +1735,22 @@ CONFIGURE_ENV+= MAKE=${GMAKE}
.include "${PORTSDIR}/Mk/bsd.gcc.mk"
.endif
+.if defined(USE_BINUTILS) && !defined(DISABLE_BINUTILS)
+BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
+BINUTILS?= ADDR2LINE AR AS CPPFILT GPROF LD NM OBJCOPY OBJDUMP RANLIB \
+ READELF SIZE STRINGS
+BINUTILS_NO_MAKE_ENV?=
+. for b in ${BINUTILS}
+${b}= ${LOCALBASE}/bin/${b:C/PP/++/:L}
+. if defined(GNU_CONFIGURE) || defined(BINUTILS_CONFIGURE)
+CONFIGURE_ENV+= ${b}="${${b}}"
+. endif
+. if ${BINUTILS_NO_MAKE_ENV:M${b}} == ""
+MAKE_ENV+= ${b}="${${b}}"
+. endif
+. endfor
+.endif
+
.if defined(USE_OPENLDAP) || defined(WANT_OPENLDAP_VER)
.include "${PORTSDIR}/Mk/bsd.ldap.mk"
.endif