aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2017-09-12 02:32:17 +0800
committerantoine <antoine@FreeBSD.org>2017-09-12 02:32:17 +0800
commit9497ea529ebc7f9d34180a1ee23dfa9284226f54 (patch)
treee92fda7fb79193a084195bd32984226ba24d8cee /Mk
parent1c0fe03c1a0c4a2fe5468d27294e30edffb8ddbc (diff)
downloadfreebsd-ports-gnome-9497ea529ebc7f9d34180a1ee23dfa9284226f54.tar.gz
freebsd-ports-gnome-9497ea529ebc7f9d34180a1ee23dfa9284226f54.tar.zst
freebsd-ports-gnome-9497ea529ebc7f9d34180a1ee23dfa9284226f54.zip
When using tcl:someversion+, prefer the default version over the highest
one if none is installed With hat: portmgr
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/tcl.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/Mk/Uses/tcl.mk b/Mk/Uses/tcl.mk
index 90068e5ed409..94250178c2fe 100644
--- a/Mk/Uses/tcl.mk
+++ b/Mk/Uses/tcl.mk
@@ -144,9 +144,13 @@ _TCLTK_WANTED_VERSION:= ${_v}
.endfor
#
-# If we couldn't find any wanted version installed, depend on the highest one.
+# If we couldn't find any wanted version installed, depend on the default or the highest one.
.if !defined(_TCLTK_WANTED_VERSION)
+. if ${_TCLTK_WANTED_VERSIONS:M${_TCLTK_DEFAULT_VERSION}}
+_TCLTK_WANTED_VERSION:= ${_TCLTK_DEFAULT_VERSION}
+. else
_TCLTK_WANTED_VERSION:= ${_TCLTK_HIGHEST_VERSION}
+. endif
.endif
#