aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1997-11-20 13:33:56 +0800
committerasami <asami@FreeBSD.org>1997-11-20 13:33:56 +0800
commita40cfd26c4afca4e66e8ea08a28dce9610bd717c (patch)
tree243f6a30ac18dc2d7f06e049cca0b21d478b74b7 /Mk
parentfb0ac15dbc01899af8ca0ca1020921c5ba357ad7 (diff)
downloadfreebsd-ports-gnome-a40cfd26c4afca4e66e8ea08a28dce9610bd717c.tar.gz
freebsd-ports-gnome-a40cfd26c4afca4e66e8ea08a28dce9610bd717c.tar.zst
freebsd-ports-gnome-a40cfd26c4afca4e66e8ea08a28dce9610bd717c.zip
Define MASTER_SITE_SUBDIR and PATCH_SITE_SUBDIR to default to "." so
we won't have double-slashes. Add support for new port variable MANUAL_PACKAGE_BUILD. If this is defined as well as the user variable PACKAGE_BUILDING, the port will be ignored. This is used to mark ports that can be built normally except on a machine that has a lot of conflicting ports (i.e., our package building machine).
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk12
1 files changed, 11 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index a9d878f59749..42b529e06f72 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1,7 +1,7 @@
#-*- mode: Fundamental; tab-width: 4; -*-
# ex:ts=4
#
-# $Id: bsd.port.mk,v 1.265 1997/10/08 05:04:48 asami Exp $
+# $Id: bsd.port.mk,v 1.266 1997/11/12 10:25:17 markm Exp $
# $NetBSD: $
#
# bsd.port.mk - 940820 Jordan K. Hubbard.
@@ -564,6 +564,10 @@ MASTER_SITE_SUNSITE+= \
MASTER_SITES?=
PATCH_SITES?=
+# To avoid double-slashes
+MASTER_SITE_SUBDIR?= .
+PATCH_SITE_SUBDIR?= .
+
# Substitute subdirectory names
MASTER_SITES:= ${MASTER_SITES:S/%SUBDIR%/${MASTER_SITE_SUBDIR}/}
PATCH_SITES:= ${PATCH_SITES:S/%SUBDIR%/${PATCH_SITE_SUBDIR}/}
@@ -748,6 +752,12 @@ IGNORE= "uses X11, but ${X11BASE} not found"
IGNORE= "is marked as broken: ${BROKEN}"
.endif
+.if (defined(MANUAL_PACKAGE_BUILD) && defined(PACKAGE_BUILDING))
+IGNORE= "package has to be built manually: ${MANUAL_PACKAGE_BUILD}"
+clean:
+ @${IGNORECMD}
+.endif
+
.if defined(IGNORE)
.if defined(IGNORE_SILENT)
IGNORECMD= ${DO_NADA}