aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-06-09 23:33:28 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-06-09 23:33:28 +0800
commitc829dec847f90199d0d7d44713c95d02395e6d35 (patch)
tree9e45cea72b2ff3ed81fca7dceb4f892eb1f7b13d /Mk
parentb246222bf190a67c421dcb4a82dc5bd01a13f149 (diff)
downloadfreebsd-ports-gnome-c829dec847f90199d0d7d44713c95d02395e6d35.tar.gz
freebsd-ports-gnome-c829dec847f90199d0d7d44713c95d02395e6d35.tar.zst
freebsd-ports-gnome-c829dec847f90199d0d7d44713c95d02395e6d35.zip
Convert most of remaining ports that depend on xorg-libraries to
modular xorg. - supply corresponding USE_XORG for all imake-using ports that need it - USE_IMAKE no longer implies USE_XLIB in absence of USE_XORG - retire USE_X_PREFIX which is not really used anywhere after the above change - a few minor nits like whitespace and SF macro Tested by: 2 tinderbox runs by pav Approved by: portmgr (pav)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk19
1 files changed, 3 insertions, 16 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index a873b1042de2..9540f4008545 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -368,10 +368,9 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# new features: 'build', 'run', 'both', implying build,
# runtime, and both build/run dependencies
##
-# USE_IMAKE - If set, this port uses imake. Implies USE_X_PREFIX.
+# USE_IMAKE - If set, this port uses imake.
# XMKMF - Set to path of `xmkmf' if not in $PATH
# Default: xmkmf -a
-# USE_X_PREFIX - If set, this port installs in ${X11BASE}. Implies USE_XLIB.
# USE_XLIB - If set, this port uses the X libraries. In the USE_LINUX
# case the linux X libraries are referenced.
# USE_DISPLAY - If set, this ports requires a (virtual) X11 environment
@@ -552,8 +551,7 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# LINUXBASE - Where Linux ports install things.
# Default: /compat/linux
# PREFIX - Where *this* port installs its files.
-# Default: ${X11BASE} if USE_X_PREFIX is set,
-# ${LINUXBASE} if USE_LINUX_PREFIX is set,
+# Default: ${LINUXBASE} if USE_LINUX_PREFIX is set,
# otherwise ${LOCALBASE}
#
# IGNORE_PATH_CHECKS
@@ -1396,18 +1394,7 @@ FILESDIR?= ${MASTERDIR}/files
SCRIPTDIR?= ${MASTERDIR}/scripts
PKGDIR?= ${MASTERDIR}
-.if defined(USE_IMAKE) && !defined(USE_X_PREFIX) && !defined(USE_XORG)
-USE_X_PREFIX= yes
-.endif
-.if defined(USE_X_PREFIX) && ${USE_X_PREFIX} == "no"
-.undef USE_X_PREFIX
-.endif
-.if defined(USE_X_PREFIX)
-USE_XLIB= yes
-.endif
-.if defined(USE_X_PREFIX)
-PREFIX?= ${X11BASE}
-.elif defined(USE_LINUX_PREFIX)
+.if defined(USE_LINUX_PREFIX)
PREFIX?= ${LINUXBASE}
NO_MTREE= yes
.else