aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2016-11-29 14:20:40 +0800
committertcberner <tcberner@FreeBSD.org>2016-11-29 14:20:40 +0800
commit01af8ed2483bf3c48720537ab6ebf9cd9e26b307 (patch)
tree6641d5c69488e6db77536287478e6a68c2586f3e /Mk
parentb708d83fc94bc9fca491794694f11801575b4510 (diff)
downloadfreebsd-ports-gnome-01af8ed2483bf3c48720537ab6ebf9cd9e26b307.tar.gz
freebsd-ports-gnome-01af8ed2483bf3c48720537ab6ebf9cd9e26b307.tar.zst
freebsd-ports-gnome-01af8ed2483bf3c48720537ab6ebf9cd9e26b307.zip
Stop exporting QT_BINDIR and QT_LIBDIR to PLIST_SUB.
As at the moment QT_BINDIR and QT_LIBDIR are 'bin' respectively 'lib' depending on the Qt version these subs ended up at many wrong places in plists. So only export it if QT_DIST is set. PR: 210227 Reviewed by: mat, rakuco Approved by: portmgr (mat), rakuco (mentor) Differential Revision: https://reviews.freebsd.org/D8378
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.qt.mk9
1 files changed, 8 insertions, 1 deletions
diff --git a/Mk/bsd.qt.mk b/Mk/bsd.qt.mk
index e208fcac734f..5e7d434d7077 100644
--- a/Mk/bsd.qt.mk
+++ b/Mk/bsd.qt.mk
@@ -271,12 +271,19 @@ USES+= qmake:_env
PLIST_SUB+= QT_PREFIX="${QT_PREFIX}"
-.for dir in BIN INC LIB ARCH PLUGIN LIBEXEC IMPORT \
+.for dir in INC ARCH PLUGIN LIBEXEC IMPORT \
QML DATA DOC L10N ETC EXAMPLE TEST MKSPEC
QT_${dir}DIR= ${QT_PREFIX}/${QT_${dir}DIR_REL}
PLIST_SUB+= QT_${dir}DIR="${QT_${dir}DIR_REL}"
.endfor
+.for dir in BIN LIB
+QT_${dir}DIR= ${QT_PREFIX}/${QT_${dir}DIR_REL}
+. if defined(QT_DIST)
+PLIST_SUB+= QT_${dir}DIR="${QT_${dir}DIR_REL}"
+. endif
+.endfor
+
.endif # !defined(_POSTMKINCLUDED) && !defined(Qt_Pre_Include)
.if defined(_POSTMKINCLUDED) && !defined(Qt_Post_Include)