aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-12-17 06:01:40 +0800
committerwg <wg@FreeBSD.org>2013-12-17 06:01:40 +0800
commit5bec478ddf547dfac784941f1b7eb68ef98e56c0 (patch)
tree15f9c6061804fcbe4fe3efb860c698444e258545 /Mk
parentc55da48dca6a5dbeab2b4f37a22ccf08b6a3aa69 (diff)
downloadfreebsd-ports-gnome-5bec478ddf547dfac784941f1b7eb68ef98e56c0.tar.gz
freebsd-ports-gnome-5bec478ddf547dfac784941f1b7eb68ef98e56c0.tar.zst
freebsd-ports-gnome-5bec478ddf547dfac784941f1b7eb68ef98e56c0.zip
Mk/bsd.python.mk: fix setup call for python 3.x
Reported by: antoine
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.python.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index 5cddb89716f9..3161ca3dea1c 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -491,7 +491,7 @@ post-install: stage-python-compileall
# distutils support
PYSETUP?= setup.py
-PYDISTUTILS_SETUP?= -c "import setuptools; __file__='${PYSETUP}'; execfile(__file__)"
+PYDISTUTILS_SETUP?= -c "import setuptools; __file__='${PYSETUP}'; exec(compile(open(__file__).read().replace('\\r\\n', '\\n'), __file__, 'exec'))"
PYDISTUTILS_CONFIGUREARGS?=
PYDISTUTILS_BUILDARGS?=
PYDISTUTILS_INSTALLARGS?= -c -O1 --prefix=${PREFIX}