aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2005-11-19 07:21:49 +0800
committerade <ade@FreeBSD.org>2005-11-19 07:21:49 +0800
commitc5a6c3ad4ca50c8f5ce25df249d7f376af21f9b2 (patch)
treed9a40cde5e260e44b535a6e2f74904f360eaceb4 /Mk
parent17d62602ffe9e8a9e31f3d6c1c4519a32ce51cb8 (diff)
downloadfreebsd-ports-gnome-c5a6c3ad4ca50c8f5ce25df249d7f376af21f9b2.tar.gz
freebsd-ports-gnome-c5a6c3ad4ca50c8f5ce25df249d7f376af21f9b2.tar.zst
freebsd-ports-gnome-c5a6c3ad4ca50c8f5ce25df249d7f376af21f9b2.zip
Rework the run-autotools target into a series of sub-targets, the
order of which can now be overriden. PR: 86309 (slightly reworked) Submitted by: thierry
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.autotools.mk35
1 files changed, 31 insertions, 4 deletions
diff --git a/Mk/bsd.autotools.mk b/Mk/bsd.autotools.mk
index 265daa371a78..5f88afc3d0a1 100644
--- a/Mk/bsd.autotools.mk
+++ b/Mk/bsd.autotools.mk
@@ -323,25 +323,52 @@ ${item:U}_ENV+= ${AUTOTOOLS_VARS}
# run-autotools
#
# Part of the configure set - run appropriate programs prior to
-# the actual configure target if autotools are in use
-#
+# the actual configure target if autotools are in use.
+# If needed, this target can be overridden, for example to change
+# the order of autotools running.
+
.if !target(run-autotools)
-run-autotools:
+run-autotools:: run-autotools-aclocal run-autotools-automake \
+ run-autotools-autoconf run-autotools-autoheader
+.endif
+
+.if !target(run-autotools-aclocal)
+run-autotools-aclocal:
. if defined(AUTOTOOL_aclocal)
@(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${ACLOCAL} \
${ACLOCAL_ARGS})
+. else
+ @${DO_NADA}
. endif
+.endif
+
+.if !target(run-autotools-automake)
+run-autotools-automake:
. if defined(AUTOTOOL_automake)
@(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${AUTOMAKE} \
${AUTOMAKE_ARGS})
+. else
+ @${DO_NADA}
. endif
+.endif
+
+.if !target(run-autotools-autoconf)
+run-autotools-autoconf:
. if defined(AUTOTOOL_autoconf)
@(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${AUTOCONF} \
${AUTOCONF_ARGS})
+. else
+ @${DO_NADA}
. endif
+.endif
+
+.if !target(run-autotools-autoheader)
+run-autotools-autoheader:
. if defined(AUTOTOOL_autoheader)
@(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${AUTOHEADER} \
${AUTOHEADER_ARGS})
+. else
+ @${DO_NADA}
. endif
.endif
@@ -349,7 +376,7 @@ run-autotools:
#
# Special target to automatically make libtool using ports use the
# libtool port. See above for default values of LIBTOOLFILES.
-#
+
.if !target(patch-autotools)
patch-autotools:
. if defined(AUTOTOOL_libtool_inc)