aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2016-12-25 20:46:14 +0800
committerbapt <bapt@FreeBSD.org>2016-12-25 20:46:14 +0800
commitf99d87f411ffb4fa28ad6a46cb5ce118a39ba946 (patch)
treeec0736641ebe66daed6945bdd8e75c9b52ebc51e /Mk
parente733252cf584b5bb2353f66edbfcc3e963ef62a1 (diff)
downloadfreebsd-ports-gnome-f99d87f411ffb4fa28ad6a46cb5ce118a39ba946.tar.gz
freebsd-ports-gnome-f99d87f411ffb4fa28ad6a46cb5ce118a39ba946.tar.zst
freebsd-ports-gnome-f99d87f411ffb4fa28ad6a46cb5ce118a39ba946.zip
Revert r429298 it has some unexpected side effects which I do not have time to
fix yet Approved by: portmgr (implicit)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.options.mk2
-rw-r--r--Mk/bsd.port.mk4
-rw-r--r--Mk/bsd.sanity.mk4
3 files changed, 6 insertions, 4 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index dfe815e6228b..193400364461 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -153,7 +153,7 @@
.if !defined(OPTIONSMKINCLUDED)
OPTIONSMKINCLUDED= bsd.options.mk
-OPTIONS_NAME?= ${PKGORIGIN:S/\//_/g}
+OPTIONS_NAME?= ${PKGORIGIN:S/\//_/}
OPTIONS_FILE?= ${PORT_DBDIR}/${OPTIONS_NAME}/options
_OPTIONS_FLAGS= ALL_TARGET BROKEN CATEGORIES CFLAGS CONFIGURE_ENV CONFLICTS \
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 7bf48ee2a4cb..17e607cfef3b 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1211,7 +1211,9 @@ USE_SUBMAKE= yes
.for _CATEGORY in ${CATEGORIES}
PKGCATEGORY?= ${_CATEGORY}
.endfor
-PKGORIGIN?= ${.CURDIR:C/${PORTSDIR}\///}
+_PORTDIRNAME= ${.CURDIR:T}
+PORTDIRNAME?= ${_PORTDIRNAME}
+PKGORIGIN?= ${PKGCATEGORY}/${PORTDIRNAME}
# where 'make config' records user configuration options
PORT_DBDIR?= /var/db/ports
diff --git a/Mk/bsd.sanity.mk b/Mk/bsd.sanity.mk
index a0e2f3f5a332..913852be5b38 100644
--- a/Mk/bsd.sanity.mk
+++ b/Mk/bsd.sanity.mk
@@ -15,8 +15,8 @@ WARNING+= "WITH_NEW_XORG and WITHOUT_NEW_XORG knobs were removed and have no eff
WARNING+= "WITH_KMS was removed and has no effect"
.endif
-.if exists(${.CURDIR}/../../Mk/bsd.port.mk) || exists(${.CURDIR}/../../../Mk/bsd.port.mk)
-.if ${PKGORIGIN:C/\/.*//} != ${PKGCATEGORY}
+.if exists(${.CURDIR}/../../Mk/bsd.port.mk)
+.if ${.CURDIR:H:T} != ${PKGCATEGORY}
DEV_ERROR+= "The first entry in CATEGORIES should be the directory where the port lives"
.endif
.else