aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2013-10-06 17:08:22 +0800
committerantoine <antoine@FreeBSD.org>2013-10-06 17:08:22 +0800
commit5bc078229a06a951f4d71b318bf754df32366cc3 (patch)
tree3a4344aed0f48582db075ef7245780eb366c88d1 /Mk
parentda517422c74bb827d65962a7ef6f6e0fcbe32259 (diff)
downloadfreebsd-ports-gnome-5bc078229a06a951f4d71b318bf754df32366cc3.tar.gz
freebsd-ports-gnome-5bc078229a06a951f4d71b318bf754df32366cc3.tar.zst
freebsd-ports-gnome-5bc078229a06a951f4d71b318bf754df32366cc3.zip
Rework linux rpm plist generation/installation
Convert linux-f10-libasyncns to STAGEDIR (only user of AUTOMATIC_PLIST) Approved by: portmgr (bapt)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.linux-rpm.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/Mk/bsd.linux-rpm.mk b/Mk/bsd.linux-rpm.mk
index 61088b9e884c..45d12133a13a 100644
--- a/Mk/bsd.linux-rpm.mk
+++ b/Mk/bsd.linux-rpm.mk
@@ -153,8 +153,8 @@ pre-install: linux-rpm-generate-plist
. if !target(linux-rpm-generate-plist)
linux-rpm-generate-plist:
cd ${WRKSRC} && \
- ${FIND} * -path ./stage -prune ! -type d | ${SORT} > ${PLIST} && \
- ${FIND} * | ${GREP} -v "^stage" | ${SORT} | ${SED} -e 's|^|@dirrm |' > ${PLIST}.dirs
+ ${FIND} * ! -path "stage/*" ! -type d | ${SORT} > ${PLIST} && \
+ ${FIND} * ! -path "stage*" -type d | ${SORT} | ${SED} -e 's|^|@dirrm |' > ${PLIST}.dirs
@${GREP} '^@dirrm' ${PORTSDIR}/emulators/linux_base-${_LINUX_BASE_SUFFIX}/pkg-plist | ${SED} 's:^@dirrmtry:@dirrm:g' | ${SORT} > ${PLIST}.shared-dirs
@${COMM} -1 -3 ${PLIST}.shared-dirs ${PLIST}.dirs | ${SORT} -r >> ${PLIST}
. endif
@@ -170,16 +170,16 @@ do-install:
. if ${BRANDELF_FILES}
@cd ${WRKSRC} && ${BRANDELF} -t Linux ${BRANDELF_FILES}
. endif
- cd ${WRKSRC} && ${FIND} * -type d | ${GREP} -v "^stage" | ${PAX} -rw ${STAGEDIR}/${PREFIX}
- cd ${WRKSRC} && ${FIND} * -path ./stage -prune ! -type d | ${CPIO} -pm -R root:wheel ${STAGEDIR}${PREFIX}
+ cd ${WRKSRC} && ${FIND} * ! -path "stage*" -type d -exec ${MKDIR} "${STAGEDIR}${PREFIX}/{}" \;
+ cd ${WRKSRC} && ${FIND} * ! -path "stage/*" ! -type d | ${CPIO} -pm -R root:wheel ${STAGEDIR}${PREFIX}
. endif
. if !target(new-plist)
new-plist: build
@${RM} -f ${PLIST}.new
@cd ${WRKSRC} && \
- ${FIND} * -path ./stage -prune ! -type d | ${SORT} > ${PLIST}.new; \
- ${FIND} -d * -path ./stage -prune -type d | ${SED} -e 's|^|@dirrm |' >> ${PLIST}.new; \
+ ${FIND} * ! -path "stage/*" ! -type d | ${SORT} > ${PLIST}.new; \
+ ${FIND} -d * ! -path "stage*" -type d | ${SED} -e 's|^|@dirrm |' >> ${PLIST}.new; \
done
. endif