aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2006-11-16 22:57:47 +0800
committerdinoex <dinoex@FreeBSD.org>2006-11-16 22:57:47 +0800
commit9dba76b06d341e4e628dfd589b6616fcf13a4d2f (patch)
treebbd12c98966235183c08564ad6ae5737db72d29f /Mk
parent0760baf64c76f60bf364eb3c1ae1d15bfeb17298 (diff)
downloadfreebsd-ports-gnome-9dba76b06d341e4e628dfd589b6616fcf13a4d2f.tar.gz
freebsd-ports-gnome-9dba76b06d341e4e628dfd589b6616fcf13a4d2f.tar.zst
freebsd-ports-gnome-9dba76b06d341e4e628dfd589b6616fcf13a4d2f.zip
- new option USE_GNUSTEP_LOCAL_TOOLS
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gnustep.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/Mk/bsd.gnustep.mk b/Mk/bsd.gnustep.mk
index 793c00647675..8f1c526835bb 100644
--- a/Mk/bsd.gnustep.mk
+++ b/Mk/bsd.gnustep.mk
@@ -81,6 +81,9 @@
# USE_GNUSTEP_LOCAL_APPS+= Ink:misc/gnustep-examples
# depends on Application installed in Local directrory at runtime
#
+# USE_GNUSTEP_LOCAL_TOOLS+= zillion:net/zillion
+# depends on Tool installed in Local directrory at runtime
+#
# ---------------------------------------------------------------------------
.if !defined(_POSTMKINCLUDED)
@@ -296,6 +299,15 @@ RUN_DEPENDS+= ${GNUSTEP_PREFIX}/Local/Applications/${_GNUSTEP_DEP:C/:.*//}.app/$
.endif
# ---------------------------------------------------------------------------
+# source local tools
+#
+.if defined(USE_GNUSTEP_LOCAL_TOOLS)
+.for _GNUSTEP_DEP in ${USE_GNUSTEP_LOCAL_TOOLS}
+RUN_DEPENDS+= ${GNUSTEP_PREFIX}/Local/Tools/${_GNUSTEP_DEP:C/:.*//}:${PORTSDIR}/${_GNUSTEP_DEP:C/.*://}
+.endfor
+.endif
+
+# ---------------------------------------------------------------------------
# source GNUstep.sh
#
.if defined(USE_GNUSTEP_CONFIGURE)