aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-09-09 18:37:03 +0800
committerbapt <bapt@FreeBSD.org>2013-09-09 18:37:03 +0800
commita068a8dcf6117f8edd598f00200133da78088cad (patch)
tree5d82425c469e8149d922801297a40347fd866aa0 /Mk
parenta3a50db87e9a67f72209d7b8a1225f60b05096e3 (diff)
downloadfreebsd-ports-gnome-a068a8dcf6117f8edd598f00200133da78088cad.tar.gz
freebsd-ports-gnome-a068a8dcf6117f8edd598f00200133da78088cad.tar.zst
freebsd-ports-gnome-a068a8dcf6117f8edd598f00200133da78088cad.zip
Introduce a new USE_CXXSTD similar to USE_CSTD to allow enforcing the C++ language standard to use when building a port
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 88b515993409..843924d9b884 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -319,6 +319,7 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# USE_GCC - If set, this port requires this version of gcc, either in
# the system or installed from a port.
# USE_CSTD - Override the default C language standard (gnu89, gnu99)
+# USE_CXXSTD Override the default C++ language standard
# USE_BINUTILS - Use binutils suite from port instead of the version in base.
##
# USE_GHOSTSCRIPT
@@ -2128,6 +2129,10 @@ CFLAGS+= -fno-strict-aliasing
CFLAGS:= ${CFLAGS:N-std=*} -std=${USE_CSTD}
.endif
+.if defined(USE_CXXSTD)
+CXXFLAGS:= ${CXXFLAGS:N-std=*} -std=${USE_CXXSTD}
+.endif
+
# Multiple make jobs support
.if defined(DISABLE_MAKE_JOBS) || defined(MAKE_JOBS_UNSAFE)
_MAKE_JOBS= #