aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorjkh <jkh@FreeBSD.org>1994-09-19 09:08:35 +0800
committerjkh <jkh@FreeBSD.org>1994-09-19 09:08:35 +0800
commitab091f2cc0348316fcb5c1b5b5371cfca79972af (patch)
treee888ca30dc945b7d120287dd27cb9e77d29edee2 /Mk
parentbfecbc2eb75830b0bad28b4d0468c0b45a38446a (diff)
downloadfreebsd-ports-gnome-ab091f2cc0348316fcb5c1b5b5371cfca79972af.tar.gz
freebsd-ports-gnome-ab091f2cc0348316fcb5c1b5b5371cfca79972af.tar.zst
freebsd-ports-gnome-ab091f2cc0348316fcb5c1b5b5371cfca79972af.zip
Modified DEPENDS rule so that anything you depend on gets both
made AND installed. Folks, check out DEPENDS if you have one port that depends on another! With this change, it should be really convenient to use.
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 2eaa92185794..8dba41399814 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3,7 +3,7 @@
# bsd.port.mk - 940820 Jordan K. Hubbard.
# This file is in the public domain.
#
-# $Id: bsd.port.mk,v 1.37 1994/09/14 15:30:44 jkh Exp $
+# $Id: bsd.port.mk,v 1.38 1994/09/19 00:41:03 ache Exp $
#
# Please view me with 4 column tabs!
@@ -214,7 +214,7 @@ build: configure pre-build
if [ ! -d ${PORTSDIR}/$$i ]; then \
echo ">> No directory for ${PORTSDIR}/$$i. Skipping.."; \
else \
- (cd ${PORTSDIR}/$$i; ${MAKE}) ; \
+ (cd ${PORTSDIR}/$$i; ${MAKE} all install) ; \
fi \
done
@echo "===> Returning to build of ${DISTNAME}"