aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2015-06-11 19:59:55 +0800
committerrakuco <rakuco@FreeBSD.org>2015-06-11 19:59:55 +0800
commitc3d1610ae066b377b895cb0b92429444d6565374 (patch)
tree181c86370f0ab6ba037c93361a60aa11307be5f0 /Mk
parent23f85fec9d16e53775aee403867014714a52c0d8 (diff)
downloadfreebsd-ports-gnome-c3d1610ae066b377b895cb0b92429444d6565374.tar.gz
freebsd-ports-gnome-c3d1610ae066b377b895cb0b92429444d6565374.tar.zst
freebsd-ports-gnome-c3d1610ae066b377b895cb0b92429444d6565374.zip
Add www/qt5-websockets.
The QtWebSockets module implements the WebSocket protocol as specified in RFC 6455. It solely depends on Qt (no external dependencies). http://doc.qt.io/qt-5/qtwebsockets-index.html Submitted by: Tobias Berner <tcberner@gmail.com>
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.qt.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/Mk/bsd.qt.mk b/Mk/bsd.qt.mk
index f1cb5e5e2b4f..33d109891ebc 100644
--- a/Mk/bsd.qt.mk
+++ b/Mk/bsd.qt.mk
@@ -96,7 +96,7 @@ USES+= tar:xz
# devel/qt*/distinfo for every port.
QT_DIST= base declarative doc graphicaleffects imageformats \
multimedia quick1 quickcontrols script serialport svg tools \
- translations webkit webkit-examples x11extras xmlpatterns
+ translations webchannel webkit webkit-examples websockets x11extras xmlpatterns
. endif
. if ${QT_DIST} == "base" && ${PORTNAME} != "qmake"
@@ -301,7 +301,8 @@ _USE_QT4_ONLY= accessible assistant-adp assistantclient codecs-cn codecs-jp \
_USE_QT5_ONLY= buildtools concurrent core graphicaleffects \
paths phonon4 printsupport qdbus qdoc qev qml quick \
- quickcontrols serialport uitools webchannel widgets x11extras
+ quickcontrols serialport uitools webchannel websockets \
+ widgets x11extras
accessible_PORT= accessibility/${_QT_RELNAME}-accessible
accessible_PATH= ${QT_PLUGINDIR}/accessible/libqtaccessiblewidgets.so
@@ -518,6 +519,9 @@ uitools_PATH= ${QT_LIBDIR}/libQt${_QT_LIBVER}UiTools.a
webchannel_PORT= www/${_QT_RELNAME}-webchannel
webchannel_PATH= ${QT_LIBDIR}/libQt${_QT_LIBVER}WebChannel.so
+websockets_PORT= www/${_QT_RELNAME}-websockets
+websockets_PATH= ${QT_LIBDIR}/libQt${_QT_LIBVER}WebSockets.so
+
webkit_PORT= www/webkit-${_QT_RELNAME}
webkit_PATH= ${QT_LIBDIR}/libQt${_QT_LIBVER}WebKit.so