aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-06-10 15:27:05 +0800
committerbapt <bapt@FreeBSD.org>2013-06-10 15:27:05 +0800
commitd87ca0d3feb92f0d3cb4a41c7162c01172e81a55 (patch)
tree49ef999a99261212bd7af3eda21234c129c43b06 /Mk
parent4aa7002d7fb28390c1d6ad21d9ed5f0d3d569b2d (diff)
downloadfreebsd-ports-gnome-d87ca0d3feb92f0d3cb4a41c7162c01172e81a55.tar.gz
freebsd-ports-gnome-d87ca0d3feb92f0d3cb4a41c7162c01172e81a55.tar.zst
freebsd-ports-gnome-d87ca0d3feb92f0d3cb4a41c7162c01172e81a55.zip
Removed useless quotes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gstreamer.mk2
-rw-r--r--Mk/bsd.options.mk43
-rw-r--r--Mk/bsd.port.mk6
3 files changed, 47 insertions, 4 deletions
diff --git a/Mk/bsd.gstreamer.mk b/Mk/bsd.gstreamer.mk
index ab29ae2cbb07..f00e58739969 100644
--- a/Mk/bsd.gstreamer.mk
+++ b/Mk/bsd.gstreamer.mk
@@ -60,6 +60,8 @@ GST1_MINOR_VERSION= .0
GST1_SHLIB_VERSION= 0
GST1_MINIMAL_VERSION= .5
+MAKE_ENV+= GI_SCANNER_DISABLE_CACHE=yes
+
#
# missing base: alsa ivorbisdec
# missing good: pulseaudio(need newer pulse version)
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index 9e2fabad02c4..7fbeb040f866 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -306,10 +306,51 @@ WITH_${opt}:= true
.endif
. undef opt
.endfor
-.endif
###
+.for opt in ${COMPLETE_OPTIONS_LIST}
+# PLIST_SUB
+PLIST_SUB?=
+. if defined(OPTIONS_SUB)
+. if ! ${PLIST_SUB:M${opt}=*}
+. if ${PORT_OPTIONS:M${opt}}
+PLIST_SUB:= ${PLIST_SUB} ${opt}=""
+. else
+PLIST_SUB:= ${PLIST_SUB} ${opt}="@comment "
+. endif
+. endif
+. endif
+
+. if ${PORT_OPTIONS:M${opt}}
+. if defined(${opt}_CONFIGURE_ENABLE)
+CONFIGURE_ARGS+= --enable-${${opt}_CONFIGURE_ENABLE}
+. endif
+. if defined(${opt}_CONFIGURE_ON)
+CONFIGURE_ARGS+= ${${opt}_CONFIGURE_ON}
+. endif
+. for flags in CFLAGS CXXFLAGS LDFLAGS CONFIGURE_ENV MAKE_ENV USES DISTFILES
+. if defined(${opt}_${flags})
+${flags}+= ${${opt}_${flags}}
+. endif
+. endfor
+. for deptype in PKG EXTRACT PATCH FETCH BUILD LIB RUN
+. if defined(${opt}_${deptype}_DEPENDS)
+${deptype}_DEPENDS+= ${${opt}_${deptype}_DEPENDS}
+. endif
+. endfor
+. else
+. if defined(${opt}_CONFIGURE_ENABLE)
+CONFIGURE_ARGS+= --disable-${${opt}_CONFIGURE_ENABLE}
+. endif
+. if defined(${opt}_CONFIGURE_OFF)
+CONFIGURE_ARGS+= ${${opt}_CONFIGURE_OFF}
+. endif
+. endif
+.endfor
+
_OPTIONS_WITHOUT_GLOBALS:= ${COMPLETE_OPTIONS_LIST}
.for opt in ${GLOBAL_OPTIONS}
_OPTIONS_WITHOUT_GLOBALS:= ${_OPTIONS_WITHOUT_GLOBALS:N${opt}}
.endfor
+
+.endif
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index a7285b836858..9ba69b3e87b1 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -6175,9 +6175,9 @@ config-conditional: pre-config
.if !target(showconfig)
.include "${PORTSDIR}/Mk/bsd.options.desc.mk"
-MULTI_EOL= ": you have to choose at least one of them"
-SINGLE_EOL= ": you have to select exactly one of them"
-RADIO_EOL= ": you can only select none or one of them"
+MULTI_EOL= : you have to choose at least one of them
+SINGLE_EOL= : you have to select exactly one of them
+RADIO_EOL= : you can only select none or one of them
showconfig:
.if !empty(COMPLETE_OPTIONS_LIST)
@${ECHO_MSG} "===> The following configuration options are available for ${PKGNAME}":