aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>2002-01-07 21:26:47 +0800
committertg <tg@FreeBSD.org>2002-01-07 21:26:47 +0800
commitf4c22016679ccf9cd158beea221ddc070c8ab6f3 (patch)
tree4f1f8e78553365f317d522244a4f0cd0e78ee5b0 /Mk
parent96fc308fec18e6cf0047447cf8baf3b5184ae043 (diff)
downloadfreebsd-ports-gnome-f4c22016679ccf9cd158beea221ddc070c8ab6f3.tar.gz
freebsd-ports-gnome-f4c22016679ccf9cd158beea221ddc070c8ab6f3.tar.zst
freebsd-ports-gnome-f4c22016679ccf9cd158beea221ddc070c8ab6f3.zip
Upgrade lang/python to 2.2. Adjust bsd.python.mk accordingly.
PR: 33444 Submitted by: Hye-Shik Chang <perky@fallin.lv> Add new MD5 to dependent ports.
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.python.mk19
1 files changed, 15 insertions, 4 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index 29c0450f6ce3..b15b446a1806 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -77,22 +77,33 @@ Python_Include_MAINTAINER= tg@FreeBSD.org
# version number is substituted and the corresponding Python distribution
# will be built through the dependency processing.
_PYTHON_VERSION!= (python -c 'import sys; print sys.version[:3]') 2> /dev/null \
- || echo 2.1
+ || echo 2.2
PYTHON_VERSION?= python${_PYTHON_VERSION}
-_PYTHON_PORTVERSION= 2.1.1
+_PYTHON_PORTVERSION= 2.2
PYTHON_PORTVERSION!= (${PYTHON_VERSION} -c 'import string, sys; \
print string.split(sys.version)[0]') 2> /dev/null \
|| echo ${_PYTHON_PORTVERSION}
+# Python-2.2
+.if ${PYTHON_VERSION} == "python2.2"
+PYDISTUTILS= ${PYTHON_LIBDIR}/distutils/core.py:${PYTHON_PORTSDIR}
+PYXML= ${PYTHON_SITELIBDIR}/_xmlplus/__init__.py:${PORTSDIR}/textproc/py-xml
+
+PYTHON_DISTFILE= Python-${_PYTHON_PORTVERSION}.tgz
+PYTHON_PORTSDIR= ${PORTSDIR}/lang/python
+PYTHON_REL= 220
+PYTHON_SUFFIX= 22
+PYTHON_WRKSRC= ${WRKDIR}/Python-${_PYTHON_PORTVERSION}
+
# Python-2.1
-.if ${PYTHON_VERSION} == "python2.1"
+.elif ${PYTHON_VERSION} == "python2.1"
PYDISTUTILS= ${PYTHON_LIBDIR}/distutils/core.py:${PYTHON_PORTSDIR}
PYXML= ${PYTHON_SITELIBDIR}/_xmlplus/__init__.py:${PORTSDIR}/textproc/py-xml
PYTHON_DISTFILE= Python-${_PYTHON_PORTVERSION}.tgz
PYTHON_PORTSDIR= ${PORTSDIR}/lang/python
PYTHON_REL= 211
-PYTHON_SUFFIX= # empty, default version
+PYTHON_SUFFIX= 21
PYTHON_WRKSRC= ${WRKDIR}/Python-${_PYTHON_PORTVERSION}
# Python-2.0