aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-12-12 20:53:03 +0800
committerknu <knu@FreeBSD.org>2002-12-12 20:53:03 +0800
commitfc89ee6b273b2ed0628b0e9067107e3e1f94a3ce (patch)
treef63c23c577fa85b226b57b1d01bc177755544f59 /Mk
parent57691fe03c6c47bd1549b8c3d8a65ac9780e12f2 (diff)
downloadfreebsd-ports-gnome-fc89ee6b273b2ed0628b0e9067107e3e1f94a3ce.tar.gz
freebsd-ports-gnome-fc89ee6b273b2ed0628b0e9067107e3e1f94a3ce.tar.zst
freebsd-ports-gnome-fc89ee6b273b2ed0628b0e9067107e3e1f94a3ce.zip
Update lang/ruby to 1.6.8-preview3, lang/ruby16-shim-ruby18 to
1.7.3.2002.12.11, and lang/ruby-devel to 1.7.3-2002.12.12. - Fix a few bugs that lead to core dump, one in the ruby interpreter and another in the syslog module. Reported by: ume (net/dtcp was a victim) - Fix an installation problem occasionally seen on bento. (a bug in Makefile that caused race) Submitted by: bento - Fix a problem that irb(1) didn't work because the symlink was wrong. Submitted by: Jos Backus <jos@catnook.com> - Get rid of move & symlink spaghetti completely from the installation process. Discussed with: portmgr (will)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.ruby.mk11
1 files changed, 7 insertions, 4 deletions
diff --git a/Mk/bsd.ruby.mk b/Mk/bsd.ruby.mk
index 91c7917cb697..016cdab2b593 100644
--- a/Mk/bsd.ruby.mk
+++ b/Mk/bsd.ruby.mk
@@ -56,6 +56,7 @@ Ruby_Include_MAINTAINER= knu@FreeBSD.org
# RUBY_DISTVERSION - The version number part of RUBY_DISTNAME.
# RUBY_PATCHFILES - PATCHFILES for the standard ruby ports, i.e. the basename of the ruby distribution tarball.
# RUBY_WRKSRC - WRKSRC for the ruby port.
+# MASTER_SITE_SUBDIR_RUBY - MASTER_SITE_SUBDIR for the ruby distfiles.
#
# RUBY_SHLIBVER - Major version of libruby (see below for current value).
# RUBY_ARCH - Set to target architecture name. (e.g. i386-freebsdelf4.3)
@@ -125,15 +126,17 @@ RUBY?= ${LOCALBASE}/bin/${RUBY_NAME}
.if defined(RUBY_VER) && ${RUBY_VER} == 1.7
RUBY_VERSION?= 1.7.3
RUBY_PORT?= lang/ruby${RUBY_R}-devel
-RUBY_DISTVERSION?= ${RUBY_VERSION}-2002.11.22
+RUBY_DISTVERSION?= ${RUBY_VERSION}-2002.12.12
#RUBY_PATCHFILES?= ruby-${RUBY_DISTVERSION}-yyyy.mm.dd.diff.bz2
-RUBY_PORTVERSION?= ${RUBY_VERSION}.2002.11.22
+RUBY_PORTVERSION?= ${RUBY_VERSION}.2002.12.12
+MASTER_SITE_SUBDIR_RUBY= snapshots
.else
RUBY_VERSION?= 1.6.8
-RUBY_DISTVERSION?= ${RUBY_VERSION}-preview2
+RUBY_DISTVERSION?= ${RUBY_VERSION}-preview3
#RUBY_PATCHFILES?= ruby-${RUBY_DISTVERSION}-yyyy.mm.dd.diff.bz2
-RUBY_PORTVERSION?= ${RUBY_VERSION}.p2
+RUBY_PORTVERSION?= ${RUBY_VERSION}.p3
RUBY_WRKSRC= ${WRKDIR}/ruby-${RUBY_VERSION}
+MASTER_SITE_SUBDIR_RUBY= ${RUBY_VER}
.endif
# defined(RUBY_VER) && ${RUBY_VER} == 1.7